It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
If I download the current version of the installer, do I still need to install the "universal update"?
This question / problem has been solved by DeMignonimage
avatar
KoreaBeat: If I download the current version of the installer, do I still need to install the "universal update"?
Yes, you do. It contains the latest version of NewDark.
avatar
KoreaBeat: If I download the current version of the installer, do I still need to install the "universal update"?
avatar
DeMignon: Yes, you do. It contains the latest version of NewDark.
OK, thanks! It sure would be nice if the main installer were updated.
avatar
KoreaBeat: OK, thanks! It sure would be nice if the main installer were updated.
Yes, you're right. I was a bit surprised myself when I saw the separate patch two years after release. Maybe there's a reason beyond my knowledge, e.g. some mods that require the old version.
avatar
DeMignon: It contains the latest version of NewDark.
actually, it doesn't, it updates the game to 2.42 - the current version is 2.43. the GOG build is due for a full update, but looks like the GOG team is too busy or something. patch up with the SS2Tool if you want to be up to date. also, there is no benefit in running the old version(s), and some mods already require 2.43, so you really should.
Post edited March 13, 2015 by voodoo47
avatar
DeMignon: It contains the latest version of NewDark.
avatar
voodoo47: actually, it doesn't, it updates the game to 2.42 - the current version is 2.43...
Thanks for clarification voodoo47. I wasn't aware that there's already a newer version than the one GOG provides, but I knew for sure the current installer still needed to be patched. As KoreaBeat said, it would be nice to get an updated installer. It might help if you'd poke support ;-)