It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
looked at every solution I have seen some just outright didn't apply or asked to do a thing that doesn't exist and none seem to fix the issue any help would be appreciated.
it's crappy to sell a non-functioning product without a label or warning.
As the other topic (in which you posted) suggests, the most likely reason to not have sound are misconfigured sound options IN GAME (not DOSBox). I had already played the game long ago and everything worked fine, but I downloaded the game ten minutes ago, and there is no problem with sound or music. I tried running the game in the different languages, and it works fine. I uninstalled it and reinstalled it by the backup download instead of Galaxy (just in case they are configured differently), and it also works fine. It's crappy to accuse GOG of selling non-functional products falsely.

If it is not too much trouble for you, run the batch file "reset_language.bat" in your install folder, so the game asks you for configuration again as it did the first time it is run. Make sure not to change anything when it asks you to set the sound configuration. The DOSBox config file is set specifically to run with Sound Blaster in Base 220, irq 7, dma 1. If the game is configured to something else, it will not work properly. Changing both the DOSBox config and the game config is of course possible, but unnecessary.

If you still have trouble after that, I am more than willing to help you. If you prefer, you can also contact GOG support directly.
Uninstall the game, confirm that your game folder was deleted and no files were left behind and then re-install the game. Once done, run the game from the desktop shortcut (i.e. don't go running or editing any files directly in the game folder just yet).