It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I can't stop the CD music from playing at top volume even with the slider set to zero.

Reading the forum, I've seen other people have problems not being able to get the music to play so I've tried some of their solutions to attempt to achieve the opposite effect.

I've disabled cloud saves, uninstalled the game, deleted the installation directory and reinstalled, but I never got the “music selection” dialog box that I’ve seen other people talk about.

I’ve seen in a post mention of adding this line “MIXER CDAUDIO 30:30” to the config file but I’m not sure what config file or where to put the line. I tried adding it to the mixer section of dosboxSWARS.conf but that didn't seem to do anything.

I tried changing nosound=false to true in dosboxSWARS.conf but all that did was disable all sound. Which, I kind of expected. I can play with no sound at all, but I'd like to have the ingame sounds.

I went to More -> Other -> Lauch Settings -> Sound and selected "No Midi music" but that also didn't do anything.

Any ideas on how to disable the music would be greatly appreciated.
This question / problem has been solved by Linksimage
I assume THIS must be one of the songs?

(Sorry, not helpful at all, but I couldn't resist...)

In an attempt to also contribute something useful, I would suggest that if no-one here can offer any good advice, you should try contacting GOG Support. In my experience, they are very helpful with technical issues like this.
I just tested this to see what is going on (I hadn't played in a long time). Sadly, the in-game volume sliders do not work (as you already say), and the setsound program does not include CD audio configuration.

Still, you can use DOSBox's mixer command to lower or turn off the volume of the CD audio, as was be suggested in that post you mention (which I did not look for, so maybe I'm reinventing the wheel).

'mixer' It is not an config option, but a command; given at the DOSBox prompt, which can be automated by adding it to the section [autoexec] of the game's config file. In this case the file for the single player configuration is "dosboxSWARS_single.conf".

It is located in the root dir of the game's installation; the same where you found "dosboxSWARS.conf" which contains the common configuration to the different setups that GOG made (single player, settings, server, and client).

You can either give the command with a 0:0 argument, to silence it, or something between 1:1 and 200:200 to set the volume.(*1)

One thing to keep in mind: the default volume is not the maximum. What you are hearing is the volume at 100, not the 200 you can go for, so go with 50 or less if you want to lower the volume considerably.

Another important fact is that the command must be given after the CD image is already mounted or it will not have any effect.

The final result should look like this:

@echo off
mount C ".."
imgmount d -t iso -fs iso "..\swars\game.ins"
mixer CDAUDIO 0:0
call play.bat


(*1) The two values are for the left and right audio channels, and can be different from one another if you want. But it is not a balance setting. It will actually lower the volume for each channel, and in the case of this game, the audio coming from each channel is not the same (truly stereo).
Post edited June 09, 2019 by Links
That worked perfectly! Thank you so much!
No problem. Enjoy!