It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
This is the message I have recieved trying to play this game. I tried running as a Admin, 640X480, changed the service pack and more. Doing all the combinations I have not been able to play the game. This is pathetic and I hope someone can find a solution.
While there might be someone in the community able to help you, it's probably best to contact GOG's support about this issue. This might also lead to patches for future players.

You should also tell the person you expect help from something about the situation the error occurs in. Like what OS you are using, maybe what graphic card you're using and also which of the 3 possible Syberia games you're referring to - this subforum is for the entire Syberia series... ;)
Best of luck!
avatar
HeartsAndRainbows: While there might be someone in the community able to help you, it's probably best to contact GOG's support about this issue. This might also lead to patches for future players.

You should also tell the person you expect help from something about the situation the error occurs in. Like what OS you are using, maybe what graphic card you're using and also which of the 3 possible Syberia games you're referring to - this subforum is for the entire Syberia series... ;)
Best of luck!
i7-3770k, Windows 7, GTX 1060 6GB SSC 16 GB RAM. I'm talking about the first Syberia.
avatar
HeartsAndRainbows: While there might be someone in the community able to help you, it's probably best to contact GOG's support about this issue. This might also lead to patches for future players.

You should also tell the person you expect help from something about the situation the error occurs in. Like what OS you are using, maybe what graphic card you're using and also which of the 3 possible Syberia games you're referring to - this subforum is for the entire Syberia series... ;)
Best of luck!
avatar
trinijunie: i7-3770k, Windows 7, GTX 1060 6GB SSC 16 GB RAM. I'm talking about the first Syberia.
Contacting gog support is probably best.

Have you tried updating all Direct X drivers? Sometimes they get corrupt or lost. The game wants Direct X 7 or better. You should get that for Windows 7 on the website of Microsoft.

Try setting compatibility settings for both game.exe and syberia.exe (I think they should exist).

It might also be worth considering to switch to the CPU-integrated GPU which should be possible via the nVidia control panel.

Also look here: https://steamcommunity.com/app/46500/discussions/0/43099722304873674/

Please have patience. This game is from 2002. That's when Windows XP was still new on the market. These old Windows-based games are becoming increasingly more difficult to get running again. I'm just saying this, because 'pathetic' is too strong a word for this issue. The system requirements say that the game wants an Intel Pentium II 350MHz and 128MB RAM with Windows XP ... getting it working on a 64bit operating system can be tricky.
Runs well with DXWnd app (available on SourceForge)

Worked with following settings for me (4K Display, Nvidia graphics, Win10 x64)

Main tab:
Run in window: on

DirectX tab:
DirectX Version Hook: DirectX 7
Rendered: gdi
Filter: PIX 2x
Full bilinear filter: on (helped to fix glitches, probably caused by DPI resizing)
Error: the 3d rendering engine could not be initialised

Right click on desktop icon, select properties then select File Location

Right click Game.exe
Select Properties
Select Compatability
Click Run this program in compatability mode for:
Select Windows XP (Service Pack 2)
Click Reduced colour Mode
Run in 640 x 480 screen resolution
Run this program as administrator
Click Apply, then OK
avatar
Surfinjo: Error: the 3d rendering engine could not be initialised

Right click on desktop icon, select properties then select File Location

Right click Game.exe
Select Properties
Select Compatability
Click Run this program in compatability mode for:
Select Windows XP (Service Pack 2)
Click Reduced colour Mode
Run in 640 x 480 screen resolution
Run this program as administrator
Click Apply, then OK
Hey, just wanted to let you know this worked for me! (Windows 10 64bit) Thanks!