It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Everytime SWAT 4 launches it causes my 2nd monitor to have epilepsy and then causes the game to crash to desktop.

No Label

Crash Time: 06/18/17 17:53:19

OS: Windows NT 6.1 (Build: 7601)
CPU: AuthenticAMD FX 8350 @ 4019 MHz with 4095MB RAM
Video: NVIDIA GeForce GTX 970 (8253)

UserName: Dean
ComputerName: DEANPC
Application location: C:\Program Files (x86)\GOG Galaxy\Games\SWAT 4\Content\System\

SWAT Build Number: 34688

Error setting display mode: CreateDevice failed (D3DERR_INVALIDCALL). Please delete your Swat4.ini file if this error prevents you from starting the game.

History: UD3DRenderDevice::UnSetRes <- CreateDevice <- UD3DRenderDevice::SetRes <- HandleBigChange <- UD3DRenderDevice::Lock <- UViewport::Lock <- UWindowsViewport::Lock <- PrecacheRenderData <- Precaching <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop->GenerateExtraCrashInfo [(GLevel: 'myLevel' PendingLevel: '(NULL)' NetMode: 'NM_Standalone'] <- MainLoop

THIS HAS BEEN FIXED
Post edited June 18, 2017 by BIGJAVLINMATE
avatar
BIGJAVLINMATE: Everytime SWAT 4 launches it causes my 2nd monitor to have epilepsy and then causes the game to crash to desktop.

No Label

Crash Time: 06/18/17 17:53:19

OS: Windows NT 6.1 (Build: 7601)
CPU: AuthenticAMD FX 8350 @ 4019 MHz with 4095MB RAM
Video: NVIDIA GeForce GTX 970 (8253)

UserName: Dean
ComputerName: DEANPC
Application location: C:\Program Files (x86)\GOG Galaxy\Games\SWAT 4\Content\System\

SWAT Build Number: 34688

Error setting display mode: CreateDevice failed (D3DERR_INVALIDCALL). Please delete your Swat4.ini file if this error prevents you from starting the game.

History: UD3DRenderDevice::UnSetRes <- CreateDevice <- UD3DRenderDevice::SetRes <- HandleBigChange <- UD3DRenderDevice::Lock <- UViewport::Lock <- UWindowsViewport::Lock <- PrecacheRenderData <- Precaching <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop->GenerateExtraCrashInfo [(GLevel: 'myLevel' PendingLevel: '(NULL)' NetMode: 'NM_Standalone'] <- MainLoop

THIS HAS BEEN FIXED
You say "This has been fixed"; how'd you do that? I'm having the same issue.
Maybe he refers to this thread: https://www.gog.com/forum/swat_series/swat_4_not_launching_properlycrashing

But for me it's not working. Can't play the game. I've read about removing other displays - but no, thanks, I'm not going to rip my living room apart in order to play a game O_o

Displays are:
A 2560x1440 primary
B 1920x1080 secondary
C 1600x1200 secondary
D 1920x1080 clone of B (TV screen on the other side of the room)

I tried running SWAT4 in windowed mode - I guess that should fix all issues - but setting the StartupFullscreen within the .ini file didn't do anything. Does anyone know how to get it into a window?
Post edited September 29, 2017 by vertex
Okay, got it convinced to start up in windowed mode.

Open \SWAT 4\Content\System\Swat4.ini and comment out (put the ; in front of) this line:

;Suppress=WindowedMode

now set this one to false:

StartupFullscreen=False

--

Now it runs in windowed mode - I could even start training - but the window sticks to the upper left corner of my screen and I can only set 1600x1200 resolution within the game. Then I tried(!) to modify some things to fix this:

BestGuessDefaultResolutionX=1600
BestGuessDefaultResolutionY=1200

WindowedViewportYPosEditor=200
WindowedViewportXPosEditor=460
WindowedViewportYPos=200
WindowedViewportXPos=460

But especially the last two lines, where it reads -23, -4 by default, become this after launch:

WindowedViewportYPos=65501
WindowedViewportXPos=65523

...it's running - kinda - now maybe someone got an idea about how to progress from here? I'd be ok with a 1600x1200 window, if I could move it around, or let it launch in the center of my screen...
Post edited September 29, 2017 by vertex
Found a solution using AutoHotkey to move and resize the window. In case anyone doesn't know what AutoHotkey is, go here: https://autohotkey.com/ (using it for years, can whole-heartedly recommend it)

Now create a new .ahk script with the following content:

WinMove, ahk_class swat4UnrealWWindowsViewportWindow, , 10, 10, 2500, 1400
Exit

The first 10 is window position from top, the second 10 is position from left, the 2500 is window width and 1400 is window height. Just edit to your likings! :-)

In combination with the windowed-fix above, it runs splendid now! (yay)
Post edited September 29, 2017 by vertex