It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
so the game is fine on the main menu, when i go onto career the game goes slow and the mouse speed drops that its just unplayable. Also the frame rate is slow in the game aswell. ive played with the resolution and went into the properties played with the launch options, reduce colour mode etc. still nothing . Please help!
Exact same issue here is how i fixed it
on the shortcut added -window to make it view in window mode

change the compatibility to windows xp sp3
and the color to 16 bit

should all be on the same tab. this will get the game playable.
That's not a fix. That's a ductape solution. I hope GOG has a windows 8 compatibility fix in the pipes.
The game requires the "8And16BitAggregateBits" compatibility flag. This can be set through the Microsoft Compatibility Toolkit. Performance will be greatly improved once the compatibility DB has been installed.
avatar
AdamK47: The game requires the "8And16BitAggregateBits" compatibility flag. This can be set through the Microsoft Compatibility Toolkit. Performance will be greatly improved once the compatibility DB has been installed.
I downloaded the App Compatibility Toolkit 5.6, but I can't find this "8And16BitAggregateBits" compatibility flag you're talking about.

Any way you could do a step by step little writeup? I've got a newborn and so my free time to work out this stuff is limited, so sorry if it turns out to be obvious :)
Here's a screenshot of the compatibility DB I created with the tool. You need to create a new fix, give it a name, executable file location, and then click next. The selection is near the top of the compatibility modes list. Click on the Test Run to confirm the fix. After that you click on Finish and then click on the Save button (give it a name and location to save the DB). Once saved, right click on the custom DB from the program and select "install". This will save the changes permanently on your system.

Edit: Make sure you use the 32-bit compatibility administrator. SWAT 3 is 32-bit so it won't work with the 64-bit compatibility administrator.


There is also another way to set the compatibility for SWAT 3. Since "8And16BitAggregateBits" is a compatibility mode and not an individual fix you can add a registry entry for the SWAT3 executable. All you need to do is copy and past the following into a txt document, edit it with the correct exe path, and then save it with a .reg extention. Once saved, just double click on it to add it to the registry.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Games\\SWAT3\\swat.exe"="8And16BitAggregateBits"
Attachments:
Post edited January 01, 2014 by AdamK47
oh my god! it is works! thanks
I found the above registry fix wasn't quite enough for Swat3 to behave properly. It could still lag when opening interface items etc.

I looked at the settings other games were using and modified accordingly (and now swat3 behaves how it should for me):

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Location\\to\\game\\swat.exe"="~ DWM8And16BitMitigation Layer_ForceDirectDrawEmulation RUNASADMIN HIGHDPIAWARE"

Notice the double slashes in the path to the swat.exe.

Warning: Just noticed the above forces it to software mode, no wonder it worked!
Post edited February 03, 2014 by chiefwhosm
Hey folks, I found a solution! Some lovely person has made a fix based off WineD3D for win8's directdraw incompatibility, all you need to do is drop some .dll files into your game directory.

gog won't let me post links but google:

[Solution] Poor performance in Windows 8 (Nvidia)

and you'll find a steam forum post with links.
avatar
m0rphine: Hey folks, I found a solution! Some lovely person has made a fix based off WineD3D for win8's directdraw incompatibility, all you need to do is drop some .dll files into your game directory.

gog won't let me post links but google:

[Solution] Poor performance in Windows 8 (Nvidia)

and you'll find a steam forum post with links.
Does the WineD3D allows you to run in Hardware Accelerated (D3D) Mode? or is it only for software? sorry to ask,,,
avatar
m0rphine: Hey folks, I found a solution! Some lovely person has made a fix based off WineD3D for win8's directdraw incompatibility, all you need to do is drop some .dll files into your game directory.

gog won't let me post links but google:

[Solution] Poor performance in Windows 8 (Nvidia)

and you'll find a steam forum post with links.
avatar
hafitz: Does the WineD3D allows you to run in Hardware Accelerated (D3D) Mode? or is it only for software? sorry to ask,,,
It allows hardware mode. The only problem I've noticed is that the PiP seems broken, so the optiwand/squad windows don't work sadly.
avatar
AdamK47: The game requires the "8And16BitAggregateBits" compatibility flag. This can be set through the Microsoft Compatibility Toolkit. Performance will be greatly improved once the compatibility DB has been installed.
avatar
kondor999: I downloaded the App Compatibility Toolkit 5.6, but I can't find this "8And16BitAggregateBits" compatibility flag you're talking about.

Any way you could do a step by step little writeup? I've got a newborn and so my free time to work out this stuff is limited, so sorry if it turns out to be obvious :)
I'm in the same boat "8And16BitAggregateBits" simply isn't a compatibility flag that shows up on the list.
avatar
AdamK47: The game requires the "8And16BitAggregateBits" compatibility flag. This can be set through the Microsoft Compatibility Toolkit. Performance will be greatly improved once the compatibility DB has been installed.
This definitely helps a lot. The mouse movement is vastly improved in the menus! Nice work.

The only problem is that the 3D portion of the game is laggy for me. Not sure if this is just my laptop though because I am using my onboard ATI video chip on the motherboard and the CPU is only 1.8 GHZ - 2.1 GHZ. It is a cheap laptop.

I suspect this fix doesn't make the game run perfectly but it helps a lot.
Post edited December 06, 2014 by Slippery_Jim
avatar
AdamK47: The game requires the "8And16BitAggregateBits" compatibility flag. This can be set through the Microsoft Compatibility Toolkit. Performance will be greatly improved once the compatibility DB has been installed.
avatar
Slippery_Jim: This definitely helps a lot. The mouse movement is vastly improved in the menus! Nice work.

The only problem is that the 3D portion of the game is laggy for me. Not sure if this is just my laptop though because I am using my onboard ATI video chip on the motherboard and the CPU is only 1.8 GHZ - 2.1 GHZ. It is a cheap laptop.

I suspect this fix doesn't make the game run perfectly but it helps a lot.
It's not your laptop, I own the original Swat 3 PC Retail version. I patched it to the latest. And still can't run on D3D with smooth framerates. Am using GTX 780 ti btw. So its not your laptop.
Game works fine on my old Windows 98 PC with ATI 9550. So it's definitely a windows 8 issue.