It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

high rated
Hey everyone! I've (hopefully) great news for Summoner fans here that have found the game somewhat less enjoyable given the game's speedup issues on better hardware these days. Here's what I won't tell you that you may have already heard:

I will not tell you to force enable VSync in your Catalyst Command Center or Nvidia Control Panel alone.
I will not tell you to set up a particular power plan to somehow try to reduce processor power directed towards your software.
I will not tell you to download a patch from Moddb.

Instead, I will tell you to download a Glide Wrapper for older games, that to my amazement was still a live link a decade later. It's an extremely simple tool to use (for the most part), and has resolved the following problems for me:

Fast forwarding through cutscenes. This was the biggest gamebreaker for me, personally. Since much of the story is told through cutscenes, it diminishes the experience to find that you can't watch them, and as most of the praise directed towards this game is in its story, I especially got the sense I was missing a lot.

Immediate game speedup after cutscenes. Initially, I didn't experience these (or couldn't tell that I was experiencing these), due to the game already running far faster than I felt it should have been, but after configuring the Glide Wrapper, I found that I did. The solution was as simple as doing what many others had advised in other threads concerning this issue.

Without further ado, here's how you sort everything out:

Download the Glide Wrapper.
Save it wherever you like, I placed it in a folder named Glide Wrapper in my Summoner folder.
Open Configurator.exe and ignore the .dll prompt, they're not an issue.
Click Application Specific Overrides, scroll down to Summoner.
Override Vertical Sync with By app, pedantic.

From there, you're not 100% done, as mentioned above.

Go to Nvidia Control Panel (right click your desktop, should appear under create shortcut), manage 3D settings, Program Settings, Add (go to your Summoner directory, select Sum.exe, not sure that Summoner.exe does anything), choose On for the VSync setting.

Go to Catalyst Control Center (right click, should be at the top as either Graphics Properties or literally Catalyst Control Center). Go to Gaming, 3D Application Settings, everything else can probably be left alone, go down to Wait for Vertical Refresh, switch it to Always On, save profile to Sum.exe.

With all this done, you're set! Better yet, it's compatible with Timeslip's unofficial patch. =)

That being said, here's a minor caveat, I'm not totally certain the Glide Wrapper was as necessary as I thought. I had some issues tinkering with it (e.g. don't mess with the resolution limit before reading what it does...That gave me more issues than I care to admit) and had to restart my PC to get around that. (It and some other settings I had going reduced the resolution, had the taskbar still visible, and while the game was otherwise fully visible, I could only interact with the lower righthand corner. That incidentally prevents you from exiting the game if you start or load a game, as you then can't get the cursor over to yes on the quit dialog.)

As far as I know, it may have installed some crucial .dlls I was missing and that's all I needed, or copying over the glide .dlls to another folder and replacing them in their appropriate directories did the trick. Either way, I know for a fact that this somehow resolved my problems, and for anyone else experiencing the same problems, I recommend giving it a shot, just follow my instructions and you shouldn't run into the problems I did.

-Download Glide Wrapper.
-Install wherever, run Configurator.exe, select application specific overrides, scroll down to Summoner, select Vertical Sync, switch to By app, pedantic.
-Go to Nvidia Control Panel (right click, sub create shortcut), manage 3D settings, add Sum.exe, scroll down to vertical sync, select On.
-Go to Catalyst Control Center (right click, top option), Gaming, 3D Application Settings, scroll down to Wait for Vertical Refresh, switch to Always On, save profile to Sum.exe.

Potential alternative solution:
-Cut and paste glide dlls (glide.dll, glide2x.dll, glide3x.dll in c:\Windows\SysWOW64; glide2x.dll, glide3x.dll in c:\Windows) into another folder, then back into their original places. I have no idea if this will work, it's a hunch from disabling all the overrides in GlideWrapper, and leaving it all up to VSync activation in my graphics card control panel. If this doesn't work, see above.