It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

As the title states, as soon as I start a new game, it jumps past the intro cutscene and tosses me into the tutorial stuff. Click through that and I discover my character is not only a summoner, but capable of miraculous gliding across the terrain without ever having to set foot to the ground...Unless I want to talk to someone or fight, that is.

I'm...Not really sure what to do with this. Tried hard enabling VSync from Nvidia Control Panel, disabling threaded optimization (this game shouldn't use multiple cores, but hey, if it does...), and so on with no luck. I also tried an alternate power plan suggestion per the Steam discussion board, with no luck there either.

Edit: Minor update, cutscenes still instantly skip but after reaching the world map and Lenele, my character's movement animations finally kick in properly. Regardless, I'm still pretty sure with it as-is, I won't be able to see any of the cutscenes. =/
Post edited June 18, 2014 by Gmr_Leon
No posts in this topic were marked as the solution yet. If you can help, add your reply