It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Good morning people.

Having discovered that GOG actually has a Pc Version of Summoner i instantly got it, remembering that it was quite a fun game.
Now the Problem:
I downloaded and installed the Game no Problem. Configuration went smoothly as well. It did detect my GTX 260 (yeah i know this is ancient :D), i configured the rest of the Settings, went to press play and...... nothing ?!
It just does not do anything. Like really nothing. Sometimes i see the green "Summoner" Icon flashing in the lower toolbar (where you can see what programs are running) for a second but overall it just doesnt do anything at all.
I have tried the complete Troubleshooting guide provided in the Support Section, i have disabled and enabled nearly all Programs running in the background, updated all my drivers, checked my firewall, did a fresh reinstall multiple times, moved the game folder to different partitions. I also tried to start in compatibility mode and start as admin , didnt work either. Timeslip Patch also failed me :/
Anyone experiencing the same Issues or knows of a Solution.
I really would love to play this game after like 10 years once again :)
No posts in this topic were marked as the solution yet. If you can help, add your reply
Ghostnappa: ...
My suggestion is contacting support, and remember there is a 30 day money back guarantee.
Try to run the game in Glide mode (instead of DirectX). Disadvantage: Max. resolution 800x600, but it seems to work. Moreover, Timeslip's patch produces an error message ("sum.exe doesn't work anymore").

That said, I have the same problem in DirectX mode, and my card is a Geforce 210. Let me know if you find a solution.

Edit: Summoner works in Glide mode with Timeslip's patch, if the resolution in the patch ini isn't set to something higher than 1024x768. If the patch changes anything in Glide mode, I can't tell.
If you set the the resolution to 1280x1024 (still in Glide mode), you'll find an error message like
"Sum caused an Access Violation in module glide2x.dll at 001b:069c5605"
in the errorlog.txt filer.
No error message is produced if you try to start Summoner in Direct 3D mode.
Post edited June 18, 2014 by Greywolf1
Same here. I own a GeForce 560TI.

I should have tested the game directly after I bought it. :-(.