It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

On first run game gives the following error:
Your game files may have been corrupted, try reinstalling the game.

Your game files may have been corrupted, try reinstalling the game.

Could not load file or assembly 'C:\Users\xxxxxxx\Documents\Streets of Rage 4 Save and Config\Save.bin'. The system cannot find the file specified.
at System.IO.FileStream.ValidateFileHandle(SafeFileHandle) + 0x9a
at System.IO.FileStream.CreateFileOpenHandle(FileMode, FileShare, FileOptions) + 0xa4
at System.IO.FileStream..ctor(String, FileMode, FileAccess, FileShare, Int32, FileOptions) + 0x15a
at CommonLib.reflection.bin_serialize_to_file(String, Object) + 0x5f
at BeatThemAll.MetaGame.StorySaveSlotScreen.DifficultyPopupScreen.<>c__DisplayClass0_0.<.ctor>b__0(In t32) + 0x85
at BeatThemAll.MetaGame.MenuScreen.handle_inputs(Int32, Int32) + 0x3a4
at BeatThemAll.MetaGame.MenuScreen.handle_input() + 0x3f
at BeatThemAll.MetaGame.StorySaveSlotScreen.DifficultyPopupScreen.handle_input() + 0x11
at BeatThemAll.MetaGame.ScreenManager.update() + 0x8d
at BeatThemAll.MetaGame.program.do_update() + 0x811
at CommonLib.platform.main_loop_update(Action, Int32) + 0xc6
at BeatThemAll.MetaGame.program.update() + 0x5c
at CommonLib.xna.StandaloneGame.Update(GameTime) + 0x49
at Microsoft.Xna.Framework.Game.Tick() + 0x2dd
at Microsoft.Xna.Framework.SDL2_FNAPlatform.RunLoop(Game) + 0xd86
at Microsoft.Xna.Framework.Game.Run() + 0xac
at BeatThemAll.MetaGame.program.Main(String[]) + 0x248


I already tried to uninstall and install again with admin privileges with the same result
I just ran into this yesterday. My son and I had gotten to level 10 on our first time ever booting up the game and then I found that our save slots were all empty when I booted it up the next time as well as all video settings had gone back to high from ultra of which I set it before I played it the first time. I didn't even get a message like you did. It was just gone. Since however, I have set my settings back to ultra and played up to level 5 and it seems to have stuck. In the past I have run into games like Shantae: Risky's Revenge losing its save and simply have ran the game's exe as the administrator and my save game magically came back. What I'm doing now is keeping an eye on my save and config file which the game locates in you "My Documents" folder. I will be copying that folder for a while every time I shut down the game just in case it something might happen to it.
Perhaps this will help once the patch rolls-in.