It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


After installing the game through GOG Galaxy, I'm unable to launch it. I get a fatal error message popup every time, whether I launch through Galaxy or run the executable. I have tried changing the executable's compatibility settings to Win7, but the results are the same.

Any help is appreciated.

Windows 10 x64
AMD R9 280 3 GB, Radeon Catalyst 16.4.1
Intel i5-4430
No posts in this topic were marked as the solution yet. If you can help, add your reply
It might be a long shot, but have you tried checking the windows event log if something has been noted in the Application log? It kinda looks like a message Windows would throw at you if it kills a process, at which point it might be noted in the Application log
Thanks for the suggestion. The solution was verifying/repairing the game files. An additional 1.4 GB was downloaded and then I was able to run the game.
Ahh, yeah missing or corrupt files will certainly cause trouble.

Glad to hear you got the game working :-)