It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Start out by opening registry editor by typing regedit into the search bar then go to the following location -

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

right click anywhere blank and add a new string value by typeing in the exact location you installed the game for example - G:\games\Still Life\StillLife.exe after that's done right click on what you created and click modify. In the Value data box type NT4SP5 and that's it have fun.
Thanks for this.

Whilst just doing the above didn't work what did get the game to run for me was by doing the above then right clicking on StillLife.exe and selecting properties. Then enable compatliblty mode for Windows XP (Service Pack 3). Runs fine now for me under Windows 10.