It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Tried to launch game with nvidia card for a better performance and encountered weird issue - game's screen remain pitch-black (but sounds play on background) until reaching the main menu (according to sounds), and then it crashes. Did anybody else encounter that on linux, and how did you fix it?

Using nvidia 430 via bumblebee's optirun on 4.19 kernel. No problems in other games, moreover - no problems with other games of this developer (tried steamworld dig 1 on steam, steamworld heist and steamworld quest there - all of them work without such issue). Game is fully playable on intel hd graphics (except for mediocre performance), so issue seems to only affect nvidia or nvidia+bumblebee setup.
No posts in this topic were marked as the solution yet. If you can help, add your reply