It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

While there seems to be an active pause, there's no key to switch it on and off (that I know of, found nothing in the config settings).

Maybe Space key as a default (configurable of course), that seems to work well in other city builders I played.