It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi all. I'm having trouble getting past the Launcher for X-Wing Alliance. I press the "Play X-Wing Alliance" button, the launcher disappears, and nothing happens. I'm on Windows 7. In googling the issues I've found some fixes for windows 10 (enabling direct play/legacy components in windows features, which Win7 doesn't list). The Windows 8.1 fix of running with specific iGPU/dGPU doesn't work; the game isn't listed in nVidia control panel and while I can select the dGPU by right-clicking the .exe, I can't run the game as administrator with the dGPU, as I don't have "the privilege". Per one search result I re-installed the game and ensured it's under the \Star Wars - X-Wing Alliance folder, and that didn't work. I've run it in compatibility mode for Win 95, 98, 2000, XPSP2, XPSP3, and tried running it as administrator with and without each compatibility version. TIE Fighter works fine for me, I haven't tried X-Wing. What's going on?!
No posts in this topic were marked as the solution yet. If you can help, add your reply