It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I installed Tie Fighter last night. It launched, all was well. I closed the game. 2 minutes later my Bluetooth controller (doubling as joystick, though I didn't realize it yet) powered down for inactivity. I attempted to launch the game again, it said I need a joystick to continue. In my ignorance I thought "Hmm. I wonder why it loaded then, and not now" (I hadn't noticed the controller functioning as joystick, as I didn't fly a mission right away, I was closing it down to install X-Wing next.)

So, I uninstalled Tie Fighter, with intentions to re install it, and once the uninstall was complete it clicked on in my head "oh hey! Controller = Joystick!" and I re-installed Tie Fighter, along with completing the installation of X-Wing.

Here's the problem, X-Wing loads just fine now. But Tie Fighter will not launch. I've tried every compatibility mode available to me. I've uninstalled and re-installed it several times. Restarted my PC between each go. I'm not really sure what went wrong between the first install and each following attempt.

And to make matters worse, I can't seem to submit a support ticket to's tech support..
Please help, community peoples! :-)

Thank you in advance

TL:DR My Tie Fighter game won't launch, no matter what settings I try to use for it. Admin, compatibility, etc.
This question / problem has been solved by kirghylommaximage
I had the same issue. Download this unofficial compatibility patch and see if it helps. It fixed my issues.

Join the Rebel Squadrons!
That did it! Thank you for your help good sir
I know I'm reviving an old topic, but this just started happening to me. The '98 version worked on previous installations. Now, I can't get the game to launch, but immediately get this popup message.

I've used both the offline installer and GOG Galaxy, but with the same result. I've tried various compatibility settings and both with and without the XWA D3D11 wrapper.

And unfortunately, the link to the above compatibility fix is no longer available.

Has anyone else had this problem and does anyone know of a solution?


EDIT: I should also point out the problem doesn't occur on the '98 version of X-Wing, only on Tie Fighter.
Post edited June 03, 2022 by MattmanOmega01