It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I started playing and the first half hour was fine. After that I consistently get this glitch where I can jump for an unnaturally long time. After that it seems that I get another glitch where if I stop running he will continue about 4-5 paces then stop. This is especially noticeable in that boba fett mission. Anyone know anything about this?
This is because your path through the mountains in this mission is going downhill. At least this is my explanation.
It's a glitch with the way the game handles falling and uneven surfaces, as far as I can tell. It's not something you can fix, and you'll just have to be careful in that level to try walk straight and slowly. You can cancel it with a jump... also walk towards walls so that if you do have it happen... you won't fall off the level.

This is the only level where this is an issue and if you're prepared for it, you should be fine.
I always figured it was gravity and sloping surfaces, which is annoying, but perhaps a bit more realistic than if the PC just 'stuck' to the ground. Then again, you'd think he'd have figured out a way to not slide, considering the technology.
Hey thanks for the responses, glad to hear it won't come up again in later levels. I only played the n64 version and it didn't have this glitch.
Yeah, I was wondering about this when I was playing through Gall Spaceport - it was
really infuriating trying to work around this. There was at least one challenge point where I died every time I tried to get it. Shame you don't get the jetpack until after the worst of the slopes, since once you have it you can at least save yourself if you end up slipping off. N64 version definitely didn't have this issue, that much I know.
I wonder if reducing the frame rate to 30 will help with this? I might try it later when I get home.
avatar
McFistPunch: I started playing and the first half hour was fine. After that I consistently get this glitch where I can jump for an unnaturally long time. After that it seems that I get another glitch where if I stop running he will continue about 4-5 paces then stop. This is especially noticeable in that boba fett mission. Anyone know anything about this?
I had this problem in the Ice caves of Hoth also. I'm also clipped through an elevator I riding and died instantly in the Boba Fett mission. This game needs a patch bad. Being able to set your own controls would be a plus also. I don't want the mouse to move and look. And this can't be disabled because you can only select presets
avatar
Celtic927: I had this problem in the Ice caves of Hoth also. I'm also clipped through an elevator I riding and died instantly in the Boba Fett mission. This game needs a patch bad. Being able to set your own controls would be a plus also. I don't want the mouse to move and look. And this can't be disabled because you can only select presets
You can set your own controls. Go through the presets and there should be a user configured set where you can choose your controls.

As for the Gall Spaceport sliding, for me that was a result of the game being played at too high a framerate. The GOG installation has an nvidia profile to get it running at a 60 FPS limit. Reducing this to 30 FPS stopped the sliding issue in the downhill parts of the Gall Spaceport level around the mountain in the first half of the level.

Lastly, the mouse forwards and backwards movement can be disabled by using a GlovePIE script. I posted it here:
https://www.gog.com/forum/star_wars_shadows_of_the_empire/mouse_movement/post9

EDIT: This post suggests that a AutoHotKey script can also block the mouse Y-axis:
https://autohotkey.com/board/topic/38931-ignoring-mouse-y-axis/
Post edited May 10, 2016 by korell
Thanks man, I'll give these a try. I am past Gall now so I don't know if it's going to be that big of an issue. Most people in the Forum say its not a big deal past that point. Either way, its been a nice dose of nostaglia for $5
avatar
FreakyMutantMan: Yeah, I was wondering about this when I was playing through Gall Spaceport - it was
really infuriating trying to work around this. There was at least one challenge point where I died every time I tried to get it. Shame you don't get the jetpack until after the worst of the slopes, since once you have it you can at least save yourself if you end up slipping off. N64 version definitely didn't have this issue, that much I know.
Returning to a couple of years old post as I just came to see if there is a fix to this.

I played this game earlier only on N64 and there was definitely not this kind of problem there. Never thought that the Boba Fett level was difficult before, but in this PC version it seems almost unplayable, almost as if it was an ice planet.

Visually this game does look stunning and fast in comparison to the N64 version. Too bad that the controls without the pad are kind of bad.
avatar
Puonaama: I played this game earlier only on N64 and there was definitely not this kind of problem there. Never thought that the Boba Fett level was difficult before, but in this PC version it seems almost unplayable, almost as if it was an ice planet.

Visually this game does look stunning and fast in comparison to the N64 version. Too bad that the controls without the pad are kind of bad.
It helps a little bit to cap the framerate to 30fps. It should reduce the icy physics, but the mouse controls will always be bad.