It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I beat Boba Fett and I thought it was a bit fishy that Slave 1 didn't shoot at me at all. I got its health down to 0%, then the life bar just disappeared and Slave 1 is just floating there forever exploding and the game won't let me progress.

I tried dying and the checkpoint reloads me from the boss fight, but Slave 1 is just floating there exploding.
Post edited December 22, 2019 by _ess_
No posts in this topic were marked as the solution yet. If you can help, add your reply
Nevermind, tried it again, it worked, got melted instantly, this game is impossible on Hard, lol.
I found a solution!

1. Exit the game in frustration.
2. Play the N64 version.

I hate when I encounter this, that level is long and it's all wasted because of this issue. I'd rather have a stable game with horrible frame rate than a graphically better version with a game-breaking bug.
But seriously I ran the game with one core, sped through the level and the issue didn't happen. Now to go back, get all the challenge points on Hard and see if it happens lol
So doing my speed run on Medium running SOTE.exe and Shadows.exe with 1 core the issue did not occur.

However on Hard difficulty is when the issue seems to occur regardless of # of cores running. Ship emerged from the ground and just stayed floating. I jumped off the cliff, respawned at the checkpoint and the ship became animated very willing to kill me lol.

You have to respawn before you destroy the ship.