It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Its so hard to use the mouse in the menu, once the game starts its fine.

anyone know how to slow down the mouse in the menu of the game?
avatar
Starkrun: Its so hard to use the mouse in the menu, once the game starts its fine.

anyone know how to slow down the mouse in the menu of the game?
I purchased SW:RC & SW:BF2 initially on Steam. This was an issue there as well. BF2 didn't even boot up,
so I got a refund for both & bought them here on GOG.

The mouse sensitivity option is for in game, so that doesn't even cover it..

Best bet is to use directional keys, [Enter] to select, & [Esc] to back out.

May the force be with you, and the odds be ever in your favor.. (Ooo! Nice Mashup off the top off my head.)
My work around was to set the mouse DPI so it would slow down so much it was unusable... but in the menu it was perfect lol
For me, limiting the frame rate fixed the mouse issue. Before limiting it, it was running at around 1500 FPS in the menu, I slowed it down to 144 FPS and the mouse behaves normally again.
Post edited November 25, 2015 by JiminyJickers
For those looking for a better solution, a fan patch has been made :

http://www.moddb.com/mods/star-wars-republic-commando-graphics-fix/downloads
That did the trick!