It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello fellow Debian users, Ubuntu lovers and Mint freaks!

Here you’ll find scripts allowing you to build .deb packages from your GOG installer for the Star Wars: Knights of the Old Republic games. You can install them through DPKG and remove them through any APT front-end (apt-get, aptitude, synaptic, etc.).

Download links and usage instructions can be found on the following page:
Star Wars: Knights of the Old Republic
Star Wars: Knights of the Old Republic II - The Sith Lords

I hope you’ll enjoy the ease-of-use provided by these scripts as much as I enjoy writing and tweaking them ;)

Here you go for more supported games!

-----

Salut camarades Debianistes, Ubunteros et fanas de Linux Mint !

Vous trouverez ici des scripts vous permettant de construire des paquets .deb à partir de votre installeur GOG pour les jeux de la série Star Wars: Knights of the Old Republic. Vous pouvez les installer via DPKG et les supprimer via n’importe quelle interface à APT (apt-get, aptitude, synaptic, etc.).

Les liens de télechargement et les instructions d’utilisation se trouvent sur la page suivante :
Star Wars: Knights of the Old Republic
Star Wars: Knights of the Old Republic II - The Sith Lords

J’espère que vous apprécierez le confort apporté par ces scripts autant que j’apprécie les écrire et les améliorer ;)

Pour plus de jeux supportés, ça se passe par ici !
Post edited May 03, 2017 by vv221
Update

KOTOR2: Fix a bug occuring if the installer is located in a path with spaces in directories names
I ran the installation script and now I have a tiny window where I can't click on any options. It displays the LucasArts logo in full-screen, but then scales down.

I'm running Mint 17.2 Cinnamon, 64-bit. Tried starting Kotor from the "Start menu".
avatar
Tigersong: (…)
The first thing to try would be to run the game in a virtual desktop.

1. To open the WINE configuration window, run one of the following command from a console:
KotOR: 'kotor-winecfg'
KotOR 2: 'kotor2-winecfg'

2. In the configuration window, go on the "Graphics" tab;

3. Check "Emulate a virtual desktop", and put your desktop resolution in the "Desktop size" fields;

4. Close the window with "OK".

Then run the game again, and come back to tell us if it helped with your problem ;)
avatar
Tigersong: (…)
avatar
vv221: The first thing to try would be to run the game in a virtual desktop.

1. To open the WINE configuration window, run one of the following command from a console:
KotOR: 'kotor-winecfg'
KotOR 2: 'kotor2-winecfg'

2. In the configuration window, go on the "Graphics" tab;

3. Check "Emulate a virtual desktop", and put your desktop resolution in the "Desktop size" fields;

4. Close the window with "OK".

Then run the game again, and come back to tell us if it helped with your problem ;)
I have same problem and enabling Emulate a virtual desktop help
But with "Emulate a virtual desktop" i cant only play in window which not good.
Thanks. My laptop is out of commission but I'll give this a try when it's up and running again. :)