It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I bought and downloaded the game and its in French.

I don't speak French and, as such, cannot find the option to change the language to English

How do I fix this other than treturning the game?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Go to your game shelf and make sure that the language dropdown (for the installer) is set to English. If you've downloaded the French installer, you will have to re-download.
^ That, but first change the language to something else then back to English.