It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

I bought KotOR 1 and 2 a few weeks ago (on Steam), installed them, both worked just fine without giving me any trouble, so I've put them aside for a while. Tried launching KotOR 1 again a few days ago, but without success. For some reason the game won't launch at all now. It does appear in the Task Manager, but under background processes.

I've tried every single fix I came across, but to no avail. Trying to launch in every compatibility mode (+ as Administrator), turning off frame buffer effects and shadows, turning off videos, removing the biologo.bik, leclogo.bik and legal.bik files, turning off thread optimization in the NVIDIA Control Panel, launching in windowed mode, turning on and off vsync; tried every one of them, but none of them worked.
Not to lie though, launching in Windows 98 compatibility mode did work, but when I try to start a game in this mode, my screen just turns black and immediately crashes (after character creation), after which I'm forced to reboot my computer, because it won't allow me to shut down the game via Task Manager.

I'm using a Windows 10 laptop with an NVIDIA GTX 960M graphics card. I would say my system is not the problem, because like I said, the games ran perfectly when I had just bought them, and that was on the same system, so it's really strange they don't launch at all now. Nothing changed in the meantime, except for a regular Windows update last week that I can think of, but I have no idea what this could have changed on my system.
After KotOR gave me trouble, I checked if my other games were still working, the old and the newer ones, and they all ran fine.

So I'm asking you if I'm not missing something really crucial here, and if there is any possibility to run these games ever again on my system. I fear the worst though, because every thread I came across on the internet with the same problem I am having now, didn't give me any solution either. :(
No posts in this topic were marked as the solution yet. If you can help, add your reply
Problems such as this. a game not even really starting, are often very tough to solve, since there are a million different things that could cause such behaviour and you can't even rely on an error message as a starting point... so I feel your pain.

Now, luckily we know that the game ran on your exact system (and even in Windows 10) before, which is good. This indicates that something changed between the time when it worked and now.
You mentioned a Windows update, but there may be other things that changed, though maybe you weren't aware of them or simply overlooked them. The fact that the game starts in Windows 98 compatibility mode is interesting too. The compatibility modes basically tell an application to use older DLLs and similar stuff, so this is another hint that maybe an update caused your problems somewhere. Is Windows 98 the only working mode?

You could try to check what exactly that Windows update entailed, and maybe perform a rollback to check if the game starts then. Other possible issues could be your GPU driver, anti-virus software, the usual.

I might add that being forced to reboot your computer because you can't kill the game process is highly unusual and not a very good sign, that obviously shouldn't happen.

I'm afraid I can't help you more than that, I haven't used Windows 10 at all and am not familiar with it.
I actually turned off movies in the settings and that helped.
Anatolian26: I'm using a Windows 10 laptop with an NVIDIA GTX 960M graphics card.
set the display to 1024 X 768 both in game and on your desktop i.e, run them at the screen rez that the game ui expects... this is a well known issue with WX drivers
From the PCGaming Wiki:

Game Won't Load
Find the intro movies files in the installation folder
Rename, move or remove the following files:

Worked for me.
Hi Anatolian,

This is the only thread i have found with the exact same problem i am having, except that i am running windows 8.1

Just wondering if you ever had any luck getting the game running again.
Post edited December 19, 2017 by OnlyZen
Maybe installing the KOTOR 1 Restoration Mod might help? It fixes several bugs in the game so....
OnlyZen: Hi Anatolian,

This is the only thread i have found with the exact same problem i am having, except that i am running windows 8.1

Just wondering if you ever had any luck getting the game running again.
Unfortunately no, it's still not working. Neither does KotOR 2.

And thanks for all your suggestions, guys, but I already tried all of them.
Win10 x64 - GTX680 here with 388.13 driver and both games (1 + 2) run just fine.

Another suggestion that has helped me on another game in the past, is to do a CLEAN installation of Nvidia drivers (there is a "clean install" setting during the driver setup). This will RESET the driver settings to default (and remove any custom settings you might have - take a note of them if you want to reapply them later).
As I mentioned earlier this helped me solve another game's similar issue in the past.
Hope this helps.
Post edited 5 days ago by gamayver
Wow, finally managed to get the game launch properly by following the suggestion of this guy on the Steam forums:
The way I got the game to launch is quite bizarre.

First I have set compatibility to Windows 98,
Launch the game
Close the game
Sign out of my computer (restarting should work too)
Sign back in
Set compatibility back to Windows XP SP3 and it just works.

I've tried several methods and this is the only way I got the game to work.
It was a Windows-related issue after all in my case. After launching the game in Windows 98 compatibility mode and restarting my computer afterwards, Windows did a little update, after which I was finally able to start the game in Windows XP SP3 compatibility mode. Haven't tried other compatibility modes, but they'll probably work too.

Anyway, thanks for all your time, guys. :)
Well nevermind, that didn't last very long; changing anything in the options menu makes it unlaunchable again. :/ I changed the resolution of the game, and suddenly got a black screen with only the mouse cursor visible and the menu music hearable in the background. Had to shut it down via Task Manager, but launching it again afterwards doesn't work, only if you follow the entire process all over again.

I think I'm quite done with trying to make this game work properly. :/