It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I'd been playing the game fine for a while now (except for a speeder issue a while back that got fixed), but then today on Onderon, after talking to the soldier and getting Ghent free, (all that minimally controllable cutscene), the loading screen appeared (to transport me to Ghent's place), and the loading bar went almost to the end in less than 5 seconds, where it just got stuck and the game hung (music stopped, etc,). So I Ctrl+Alt+Deled the game and loaded it again, and it hung in the exact same place. I reset my computer, loaded it AGAIN, constantly saving this time so I could be as close as possible to the problem time in case it hung again, but this time it loaded properly. I talked to Ghent, he gave me a mission, so I went to the Cantina. When I entered the door, it started the loading screen again, and...it hung just before loading was complete.

I'm going to try resetting again right now, hopefully it should work, but I would like a more permanent solution to this problem.
I'm on Windows 7, haven't installed any graphics mods, or any suspicious or unknown mods, so...anyone have any ideas as to what I can do?
Thanks in advance!
Welcome to Onderon!

Basically the only thing you can do is preservere. Turn down graphics to the mininum during loading to get the maximum chance of it to work. Then you can go back to regular again.
And you're pretty unlikely to meet this next game, while it's a common issue, I've personally had it only twice in my hundred or so playthroughs, no-one has a clue as to the why.
avatar
Hassat_Hunter: Welcome to Onderon!

Basically the only thing you can do is preservere. Turn down graphics to the mininum during loading to get the maximum chance of it to work. Then you can go back to regular again.
And you're pretty unlikely to meet this next game, while it's a common issue, I've personally had it only twice in my hundred or so playthroughs, no-one has a clue as to the why.
I have this same problem aswell.

I tried turning down the graphics and even the resolution and still nothing?