It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Up until entering the cantina on Telos, the sound for the game was fine. Now, the sound effects, music, and dialogue disappear. Sometimes the sound effects come back when I'm in the equipment section, but I'm not sure what's going on.

Restarting the game brings back the sound for awhile, but then it goes away.

Heading back out to the main menu and attempting to play music—nothing happens. No sound at all.

Restarting computer seems to only do as much as restarting the game. Sound returns for a bit, but then disappears altogether.

Anyone have a fix or suggestion?

All the sound options are on default.

Plaything this on Win10, installed all the Direct x9 (???) stuff, etc. It's really weird that the sound issues only began now.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Tried running in XP SP3 compatibility mode with the same results. Sound is present for awhile, then it sounds like someone is slowly turning down the volume and all sound disappears. Cursor sound effects in the inventory/menus returns intermittently.

Tried tuning the sound sliders all the way up, but there is no difference. Only silence.

Tried running the forced software for sound with no change.
Post edited May 31, 2017 by white_zombe
Went back to an older save on Peragus station and the sound issue is present there now as well. So seems like a file issue and not a save issue.

There was an update that my PC downloaded from M$ today, so maybe that's causing problems?

I don't know.

I even downloaded a different MS332.dll file to no effect.
Trying to look up solutions but no solutions yet. Even compatibility mode doesn't seem to work (XP SP2, ME).

Will try a re-install once I get back to good Internets.
After playing a Steam game and noticing the same issue, I did some looking around.

Eventually, I figured out that this is an uncommon Win10 problem.

Uninstalling sound drivers, then reinstalling and updating did the trick.

Boo to Win10!