It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
After the very first level there's a cutscene where apparently Skywalker is addressing the students in the temple, but he says nothing and nobody moves. He's just standing there looping an idle animation. Fortunately I can skip it but it has to either be a rare bug or something that was fixed years ago because apparently no one else is suffering from the same problem.

When the 4th cutscene in a game is bugged, am I to expect going forward that a quarter of the time I'm going to have to go online to watch the cutscenes in order to get the whole story?

EDIT: It's getting even worse. After finishing the two Tatooine missions, there's what I can only assume to be a level that is supposed to be a cutscene, but the cutscene never starts, instead I am put in control ingame, and I can seen an incorporeal stationary version of my character standing in the room. None of the characters do anything and this time I can't skip it because when you're ingame, you can't skip a cutscene.
Post edited May 07, 2018 by Platinumoxicity
No posts in this topic were marked as the solution yet. If you can help, add your reply
I've gotten the same bug where after doing two missions i'm stuck in a room with a bunch of npcs and a copy of myself. I know it's supposed to be a cutscene but I can't get it to start. I've tried verifying game files and going back to an earlier save, but it didn't change anything.
You can skip cutscenes with Enter. Do you tried rapidly pressing Enter while the game loads, possibly skipping the scene instantly?

Anyway this is one strange bug, I never encountered this but I remember Doom 3 doing the sometimes.
I got the same exact issue as the OP.... weird. You aren't the only one.
Exactly the same bug for me
Ran into the very same bug.

Playing the Steam version solved it for me.
avatar
LouisdeFuines: Playing the Steam version solved it for me.
Odd, I had the same bug with the Steam version. Using OpenJK did bypass the issue, though.
Sorry to necro this, but maybe it helps somebody:

I had the same issue on the Steam version with OpenJK installed.
Another user pointed out, that older games sometimes have problems with higher framerates and to turn on vsync in-game (Setup -> Video -> "Video Sync: On"). This fixed it for me.
I need help with this as well. I’ve tried the vsync solution, both in and outside of game, and the cutscene still freezes. I’ve run the game as administrator, verified my files, tried openjk, restarted from a previous save, restarted a new game, and restarted my computer. Can anyone help me?
Post edited November 26, 2022 by FPSnut930