It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
VspecII: Well actually it is a console game, From N64......
avatar
Faenrir: Got released the same day on PC, genius.
What i meant was that the version we got here is from the old pc version of the game, obviously.
And pc games need tweaking thus not being "plug and play" console games.
Not gonna lie Faenir, i didnt know it was released for PC as well.
So i will cop that on this chin and apollogise.
Would be nice if we got this working though..... =(
Try dgVoodoo http://dege.freeweb.hu/dgVoodoo2/dgVoodoo2.html

You might have to rightclick on SWEP1RCR.EXE and disable all compatibility options to make it work.
If they are greyed out first click on "Change settings for all users" or something similar.
avatar
Faenrir: Got released the same day on PC, genius.
What i meant was that the version we got here is from the old pc version of the game, obviously.
And pc games need tweaking thus not being "plug and play" console games.
avatar
VspecII: Not gonna lie Faenir, i didnt know it was released for PC as well.
So i will cop that on this chin and apollogise.
Would be nice if we got this working though..... =(
Hey it's alright, i thought you were teasing me, sorry for the rude tone.

A quick question to all of you experiencing that problem:
Are you using Gog Galaxy ?
(I'm not and have downloaded the installer so i'm wondering if it wouldn't be the issue here)
avatar
VspecII: Not gonna lie Faenir, i didnt know it was released for PC as well.
So i will cop that on this chin and apollogise.
Would be nice if we got this working though..... =(
avatar
Faenrir: Hey it's alright, i thought you were teasing me, sorry for the rude tone.

A quick question to all of you experiencing that problem:
Are you using Gog Galaxy ?
(I'm not and have downloaded the installer so i'm wondering if it wouldn't be the issue here)
hmmmm i do have GOG installed, have already tried launching it directly frome the launcher bypassing the installer though.... I am still troubleshooting will update you all if i find something that works.
Cheers for the help!
Not using Galaxy, changed resolution through video config, tried dgVoodoo2 wrapper, tried installing the actual audio drivers it's using with smush.dll etc, tried compatibility mode and changing colours to 16bpp, none of it works as a lasting solution. Sometimes it randomly loads, then it won't load for 20 times thereafter. The only time it actually runs is upon first install, if you uninstall it and then install again, you get the same rdroid_gnome issues.

It's broken. \o/
avatar
Varell: Not using Galaxy, changed resolution through video config, tried dgVoodoo2 wrapper, tried installing the actual audio drivers it's using with smush.dll etc, tried compatibility mode and changing colours to 16bpp, none of it works as a lasting solution. Sometimes it randomly loads, then it won't load for 20 times thereafter. The only time it actually runs is upon first install, if you uninstall it and then install again, you get the same rdroid_gnome issues.

It's broken. \o/
Yup, same here. Tried everything that was suggested here in the forums. This game is hella broken and needs to be fixed asap. It's sunday afternoon and I realy was anticipating some good old pod-racing -.-
hi everybody

it runs good for me ( with keyboard) after install dgVoodoo v2.55 in the same directory of the game run the window and dont close it
run the SWEP1RCR exe

windows 10 version 1803 ( version system 17134.1)
video settings 1920 x 1080 16 bpp

parameters in the attach files
Attachments:
Post edited May 08, 2018 by gotmog
avatar
gotmog: hi everybody

it runs good for me ( with keyboard) after install dgVoodoo v2.55 in the same directory of the game run the window and dont close it
run the SWEP1RCR exe

windows 10 version 1803 ( version system 17134.1)
video settings 1920 x 1080 16 bpp

parameters in the attach files
Hey gotmog,

The game was crashing on launch for me with the "rdroid_gnome release build has stopped working" error. Finally got past that using dgVoodoo v2.55, which I wouldn't have known about if it wasn't for your post. Thanks for the solution!

PS. Works with controller too once you enable it in the game settings. Been playing with an Xbox One pad.
Post edited May 08, 2018 by psykal
FOUND A SOLUTION that works for me (windows 10 Pro 1803).

1. Go to the game directory
2. Right-click SWEP1RCR and then "Properties"
3. Click "Compatibility" tab
4. Click "Change settings for all users" to un-grey out the boxes
5. Uncheck the box "Reduced color mode".
6. Uncheck the box "Always run as administrator"
Post edited June 28, 2018 by reifoll
Postet this yesterday in the Common Problems Troubleshooting thread. It is lot of work, but give it a try:


https://www.gog.com/forum/star_wars_episode_i_racer/common_problems_troubleshooting/post63
And to follow up @Shinzon's useful tip, here's the automated version along with a verified explanation as to why this works. Frankly I'm so freaking happy to be able to consistently play the game now, not a single other solution worked and I fully appreciate the frustration many of you are going through. If this still does not fix your issue and you've tried the other trouble shooting steps please contact me directly and I'll do my best to help so that others won't have the same problems.
Post edited July 18, 2018 by Tehelee
Remember that you can contact Support and if you and they working together can't get the game running (and you've contacted them within 30 days of purchase), you're entitled to a refund.
The game was crashing on launch for me too. win10, Nvidia geforce

I set the game to meet my display 1920 x 1024

then in geforce experience turned off the overlay and it launched!

note: you need to have the proper codecs installed too. If you play more older games you probably already have those.

I hope this helps for some of you!