It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

If I try to run the game from GOG Galaxy, I get a prompt for an administrator password, and then after I've entered it, I get the error:


Error: Please insert CD-ROM 'racer100_0' intro drive.

Press OK to continue ot CANCEL to exit to desktop.


The game then won't load. Pressing OK just gives me the same error again.

It loads fine if I use the shortcuts in the game directory itself, but I assume that means time played/cloud sync won't track correctly.

Anybody have any idea why it's doing this?
error.jpg (16 Kb)
I was trying to run this on Linux with Wine (I know it's not officially supported but please bear with me). Looks like something is messed up with the game and some of the paths are absolute and pointing to drive D:/ while other paths are relative and working:

lpFileName 0xC07FFC18 ('D:\Data\Anims\PlanetG.znm')
dwDesiredAccess 0x80000000
dwShareMode 0x3
lpSecurityAttributes 0xC07FFA50
dwCreationDisposition 0x3
dwFlagsAndAttributes 0x80
hTemplateFile 0x0
Failed to open file ('D:\Data\Anims\PlanetG.znm' as 'd:/data/anims/planetg.znm')
Stack at 0xC07FFA18; returning EAX: 0xFFFFFFFF
306 Emulation at 4A077D ('CreateFileA') from 4A077D

hWnd 0x14D
lpText 0xC07FFD18 ('Error: Please insert CD-ROM 'racer100_0' into drive.

Press OK to continue or CANCEL to exit to desktop.')
lpCaption 0x4B7DBC ('CD ERROR')
uType 0x31
Stack at 0xC07FFA68; returning EAX: 0x00000002
314 Emulation at 4257CD ('MessageBoxA') from 4257CD

lpPathName 0x4B4F6C ('.\data\player\')
lpSecurityAttributes 0x0
Stack at 0xC07FF950; returning EAX: 0x00000001
315 Emulation at 48431D ('CreateDirectoryA') from 48431D

After messing with winecfg and adding drive D:/ pointing to /home/username/.wine/drive_c/GOG Games/STAR WARS Racer/ the error goes away. Game tries to run but I get "Unable to open display for 3D" which is another issue probably not related to game itself.

Debug info I got while I was trying to run game through (open) source port:

I've send the message to Support team as well

For Windows users: try to move/copy game data to drive D so the paths would be e.g. D:\Data\Anims\PlanetG.znm or create shortcuts or create/emulate/mount virtual drive etc...
Post edited May 06, 2018 by tonysrak
Please do not contact the support with information gained from OpenSWE1R. Instead, keep those issues on the OpenSWE1R repository.
Also check the ongoing research in the existing issue about support (OpenSWE1R/openswe1r #142).

Reason: OpenSWE1R contains (hacky) CD drive emulation. The OpenSWE1R CD drive emulation modifies path and is incompatible with the no-CD patch (which also changes those path). So the debug output can not really be trusted for non-OpenSWE1R situations as the output might be misleading.
Furthermore, the release is not yet officially supported in OpenSWE1R (yet).

We'd love to have more developers. I mostly wrote OpenSWE1R on my own (and do a ton of related reverse engineering). I'm currently busy helping Olganix to make a map/model-editor for this game.
Post edited May 06, 2018 by JayFoxRox
Of course those are two different projects but OpenSWE1R allowed me to debug path issue that worked with GOG version. I've added D:\ path to Wine and it worked so the *issue was with GOG version* and as a bonus I added information from OpenSWE1R.

Of course I realize that this game is not officially supported by neither Wine nor OpenSWE1R. I just wanted to provide feedback.

Current GOG version (hotfix2) works with Wine (cd ~/.wine/drive_c/GOG Games/STAR WARS Race first).

To change resolution run wine SWEP1RCR.EXE -v