It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Alright, I've tried every damn fix on this Bindoo-forsaken forum to try and get Jedi Knight to work on my PC, but the best I've got for my efforts is a black screen with visible hud elements and the game apparently functioning (Thanks to the audio cues). Will somebody please offer something, I've been working on this damn thing for HOURS now
This question / problem has been solved by jnisbetimage
Try my instructions from the 3D acceleration thread. If you've already tried them and found that the links in steps 1 & 2 were dead, follow them again, because I fixed the links.

I wish those new updated links you provided were more accessible. I'm sure there are a lot of people like me who don't have the patience do deep-dive into the forums. If I were you, I'd make a new thread and try to get it stickied or at least bumped like ye olden days
Fuck that I refuse to use a god damned voodoo wrapper you take my fucking money you present a working game