It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi everyone,

I've noticed a few people have had this issue, but haven't seen any confirmed solution. This issue has nothing to do with screen size, since the crosshair and HUD don't appear regardless of screen size. Other than this, the game runs perfectly with 3D Acceleration on. With 3D accel off, the screen is completely black.

Cheers for your help
This question / problem has been solved by Xitramimage
I had the problem with no crosshair (you've surely read my postings) but i solved it by installing the newest drivers.
Post edited February 01, 2015 by Xitram
I've got the latest drivers. Also tried the antialiasing-off trick. No love whatsoever. Its perfectly playable... but I just cant see the HUD or crosshair.

Also, all the text messages in the top left of the screen are miniscule, regardless of the resolution I pick.
Have you tried out the jkultimate patch ?
I gave it a shot, but don't think I installed it correctly because I went from no HUD to no graphics at all (black screen, and a crash I think).

Do I transfer all .dll files into the main directory, or just the related one?
You have to unzip all files into the main directory and overwrite when asked.
Post edited February 02, 2015 by Xitram
avatar
Xitram: You have to unzip all files into the main directory and overwrite when asked.
I thought I did this the first time, I guess not!

Thanks a bunch mate. Man, its awesome to play JK and MotS again!
I can't see the crosshair but can see the HUD, didn't realise there was one until I saw this.
This is marked as Solved, but I don't understand what the solution is. I also cannot see the crosshair in hardware mode, even though the HUD is visible. So how do we fix it?
avatar
ThreeSon: This is marked as Solved, but I don't understand what the solution is. I also cannot see the crosshair in hardware mode, even though the HUD is visible. So how do we fix it?
Download dgVoodoo and extract DDraw.dll, D3DImm.dll and dgVoodooSetup.exe to the game directory.
http://dege.freeweb.hu/dgVoodoo2.html
It's a wrapper that's also included with the ultimate patch mentioned above.

Run dgVoodooSetup.exe to disable the dgVoodoo watermark.
avatar
ThreeSon: This is marked as Solved, but I don't understand what the solution is. I also cannot see the crosshair in hardware mode, even though the HUD is visible. So how do we fix it?
avatar
teleguy: Download dgVoodoo and extract DDraw.dll, D3DImm.dll and dgVoodooSetup.exe to the game directory.
http://dege.freeweb.hu/dgVoodoo2.html
It's a wrapper that's also included with the ultimate patch mentioned above.

Run dgVoodooSetup.exe to disable the dgVoodoo watermark.
Unfortunately I tried using this, but the result was that the in-game graphics became un-readable - everything is in black and white when using this wrapper. I couldn't find any setting or toggle in the dgVoodoo setup that would fix it.
Is the crosshair visible in Software mode? If not then it might be turned off in Setup->Gameplay.

Also there's an old wrapper that allows adding a custom crosshair to the game.
http://www.jkhub.net/project/get.php?id=808
avatar
teleguy: Is the crosshair visible in Software mode? If not then it might be turned off in Setup->Gameplay.

Also there's an old wrapper that allows adding a custom crosshair to the game.
http://www.jkhub.net/project/get.php?id=808
The crosshair is enabled in the game settings, it just doesn't show in hardware mode. That wrapper works, for the most part, although the included crosshair image has two crosshairs for some reason, and they're both higher than the actual in-game aim. But I should be able to edit that for a fix.