It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi all!

Anyone tried multiplayer with the gog version?
Does it work "out of the box" or are there some special fixes I sould try.
Finally any tips on finding mutiplayer hosts/games?
I play Multiplayer with bots. On Steam I found on the forums a thread, where it is explained to download "Rbots" for JK1 and MotS. The guy later created an steam guide. The bots work very well and it makes fun to play with them.

Real Multiplayer should be only possible with hamachi I guess, so you would need to know someone who also wants to play MP. I think there are no real servers anymore, aren't there?
According to

Steam and GOG do not provide the required DirectPlay registry keys to play Jedi Knight and Mysteries of the Sith on DirectPlay gaming services such as Voobly or GameRanger.
I've tried playing on my local network but the clients never found the game I had set on another host. I might be wrong but I'm almost sure it's because of the aforementioned quote.


The message above means these clients won't automatically find the game, but it still works either by manually providing the install folder, or by adding those registry keys manually.

The GameRanger client was very helpful to diagnose issues with my router. Apparently, my ISP had the firewall disabled, enabling a "block-all mode" instead, where it would ignore my port forwarding settings and even block LAN game traffic. After enabling the firewall, my modem stopped ignoring my port settings.

I've tried multiplayer between my desktop (Windows 7, GOG original) and notebook (Windows 10, GOG version patched with dgVoodoo) and it works. Apologies to anyone who got misled by my original message.
Post edited October 26, 2015 by Mr.Whitney