It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I have a problem with Jedi Knight that I have not seen. I reported it to GOG but I'll post it here hoping some among you might shed some light about this.

I have a AMD Radeon R7 250x with up to date drivers on Windows 7 (64 bit).

When I start Jedi Knight I get the results show in the first image attached. Since the elements in the screen can be still seen, I've managed to shutdown the game only to discover that the effect lasts after the game exits, as can seen in the second image.

I'd suspect of the hardware but this is the only game giving me problems.

I tried a 1280x720 resolution with and without hardware acceleration with the same results. I have not tried othe resolutions as every test implies rebooting my system which is a PITA to say the least.

No mods of any kind installed.

Any thoughts?
Attachments:
No posts in this topic were marked as the solution yet. If you can help, add your reply
I'm having the same problem.

I've noticed that if I can get into the game without any of the cut scenes playing there is no problem. Once I finish a level and the cut scene for the next level plays then the problem reappears.

Any idea what codec is used to play the cut scenes? I've had no luck finding it. Perhaps a current version of the codec will fix the problem.