It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello, I just bought this from GOG and installed it on an old computer running windows XP, but it won't run.
It gives a generic error message of "This application failed to start" and suggests I reinstall it. But that doesn't change anything; I've actually installed it on two different machines with different hardware (both running XP) and they both give the same error.
Please advise.
This question / problem has been solved by el.zwierzakkoimage
That's a pretty vague error message...maybe you can try OpenJK and see if that helps.
avatar
zollac: That's a pretty vague error message...maybe you can try OpenJK and see if that helps.
I'm pretty sure he is referring to Dark Forces II. Doesn't OpenJK only work for Outcast and Academy?
avatar
zollac: That's a pretty vague error message...maybe you can try OpenJK and see if that helps.
avatar
SirYodaJedi: I'm pretty sure he is referring to Dark Forces II. Doesn't OpenJK only work for Outcast and Academy?
Correct; Dark Forces II: Jedi Knight.
Ah, sorry, thought it was JK2.

Have you tried usual tricks like compatibility mode?
I don't know how to run a compatibility mode for this.

I just tried an experiment, though. I tracked down my original disc for the game and installed it with that. The version that installed from my disc is fine (well, the game doesn't actually run in full screen, it has black space around every edge except the top, rather annoying,)
However, I want to run the GOG version. That way I get the expansion and I don't have to use the CD. I'm setting up a series of old computers and I'd like to network them all together for multiplayer.

The message I get when I run the GOG version is "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem." Is there a settings file I can try copying from the other install, or osme setting I might need to adjust?
This is a clean install of Windows XP with nothing else on the computer; just the OS, drivers, and games. I even made sure to update one of these computers to Service Pack 3 and it still doesn't run the game.
Have you tried running the JK.EXE from the installation folder directly? For some reason I can't start the game using the desktop short cut. It goes to "Star Wars Jedi Knight - Dark Forces 2\JKStart.exe" and not JK.EXE directly. I found that to be the problem for me. Also on XP mind you. No such problems on windows 7.
Maybe try the 2013 updated exe.

Found here: https://www.moddb.com/downloads/jedi-knight-2013-unofficial-patch-jk13
avatar
el.zwierzakko: Have you tried running the JK.EXE from the installation folder directly? For some reason I can't start the game using the desktop short cut. It goes to "Star Wars Jedi Knight - Dark Forces 2\JKStart.exe" and not JK.EXE directly. I found that to be the problem for me. Also on XP mind you. No such problems on windows 7.
OMG that works!!
Glad I could help.