It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
jnisbet: I've gotten the GOG version of Jedi Knight working in 64-bit Windows 10 with 3D acceleration, mod support AND music by doing three things:

1. Extracted this pre-patched JK Unofficial Patch to the game folder. This enables mod support and is needed for the next step.

2. Extracted this 32-bit Display Mode Patch to the game folder. This is one of the ddraw.dll files that fixes 3D acceleration.

After doing those two things, I was able to go into Setup->Display and select a 32bpp resolution (which you need to get working 3D acceleration instead of a black screen). If you still can't select a 32bpp resolution, then try extracting [url=http://jkdf2.com/files/ddraw_(hack_viewport3_clear2).zip]this alternate ddraw.dll[/url] to the game folder, instead.

At this point, I had working 3D acceleration and mod support, but no "CD" music (i.e. no music after walking out of the bar). That made sense at first, since I was now using a different version of JK.exe than the GOG version, but it turned out that it wasn't that and that the fix to get music working again was very simple...

3. Renamed JK.exe to something else (I chose JediKnight.exe) and updated the shortcut.

When I discovered that that fixed the problem and I was getting music again, I went digging through the registry and found the culprits:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Custom\JK.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

Once I deleted the JK.exe key and the reference to JK.exe under the Layers key (don't delete the Layers key, just the value inside it which references JK.exe), I was able to rename the executable back to JK.exe and still got music. For people who aren't comfortable with editing the registry and want a simple solution, though, renaming JK.exe to something else does the job just as well. Try it if you've gotten 3D acceleration working, but are now not hearing music after you leave the bar.
THANK YOU!!!



This method works perfectly for me, but only for the original Jedi Knight: Dark Forces II and not on the Mysteries of the Sith expansion. Is there a similar method to enable 3D acceleration on MotS?
Post edited June 15, 2017 by mattyeomans
Here's how to get 3D acceleration, mod support and music working in Mysteries of the Sith under Windows 10 (x64):

1. Extract this pre-patched Unofficial Patch to your game folder. This improves compatibility with modern Windows and enables many mods and fixes to work.

2. Extract these dgVoodoo files to your game folder. This should fix 3D acceleration.

3. Download and extract this fixed winmm.dll wrapper to your game folder. This fixes a few issues with music playing.

4. Rename JKM.exe to something else (like JediKnight.exe). That should fix missing music on Windows 10. Alternately (especially if that doesn't help), you can download and import a registry file (read the instructions in a text editor first, though).

That should be enough for most users, besides enabling 3D acceleration and a 16bpp resolution in the game.

If the above does NOT work, probably because you have an ancient computer, here's how I got the game running on my laptop:

5. Delete the four dgVoodoo files that you added in Step 2 or simply rename DDraw.dll to disable it. At this point, you might try another ddraw.dll from JKDF2.com, but I had no luck.

6. Download, extract and run DxWnd.

7. Drag your renamed JKM.exe onto the DxWnd window, right-click on the entry that's created and choose Modify.

8. On the Main tab, de-select "Run in Window."

9. On the Video tab, change "Screen resolution" to "Monitor native modes" to have your monitor's resolutions show up in the game.

10. On the Direct3D tab, change "Texture Handling" to "Hack" to solve texture smearing problems.

11. Run the game either by double-clicking on it in the DxWnd window or the way that you usually do (via shortcut or running the .exe directly), but while DxWnd is running. Either way, DxWnd has to be running while the game is in order for it to work.

I think that I've covered everything. On my desktop computer, the first option (dgVoodoo) works for 3D acceleration. On my ancient laptop, only the second option (DxWnd) works. Hopefully, one of those two will work for you.
Post edited November 19, 2017 by jnisbet
After trying and trying with both a Steam and GoG installation the only thing that worked to get hardware 3D rendering was applying the fixes to a version installed from an iso. Too bad GoG can't sell a better pre-patched version to save any of this hassle.
Firefox is telling me that the file containing the dgVoodoo files are infected with a virus.
avatar
jnisbet: Here's how to get 3D acceleration, mod support and music working in Mysteries of the Sith under Windows 10 (x64):

1. Extract this pre-patched Unofficial Patch to your game folder. This improves compatibility with modern Windows and enables many mods and fixes to work.

2. Extract these dgVoodoo files to your game folder. This should fix 3D acceleration.

3. Download and extract this fixed winmm.dll wrapper to your game folder. This fixes a few issues with music playing.

4. Rename JKM.exe to something else (like JediKnight.exe). That should fix missing music on Windows 10. Alternately (especially if that doesn't help), you can download and import a registry file (read the instructions in a text editor first, though).

That should be enough for most users, besides enabling 3D acceleration and a 16bpp resolution in the game.

If the above does NOT work, probably because you have an ancient computer, here's how I got the game running on my laptop:

5. Delete the four dgVoodoo files that you added in Step 2 or simply rename DDraw.dll to disable it. At this point, you might try another ddraw.dll from JKDF2.com, but I had no luck.

6. Download, extract and run DxWnd.

7. Drag your renamed JKM.exe onto the DxWnd window, right-click on the entry that's created and choose Modify.

8. On the Main tab, de-select "Run in Window."

9. On the Video tab, change "Screen resolution" to "Monitor native modes" to have your monitor's resolutions show up in the game.

10. On the Direct3D tab, change "Texture Handling" to "Hack" to solve texture smearing problems.

11. Run the game either by double-clicking on it in the DxWnd window or the way that you usually do (via shortcut or running the .exe directly), but while DxWnd is running. Either way, DxWnd has to be running while the game is in order for it to work.

I think that I've covered everything. On my desktop computer, the first option (dgVoodoo) works for 3D acceleration. On my ancient laptop, only the second option (DxWnd) works. Hopefully, one of those two will work for you.
I did steps 1-4 (similar steps worked for me with Dark Forces 2) and now i'm asked for jedi knight CD number 2. I bet this is because of the new JKM.exe? What can i do about this?
Post edited November 19, 2017 by Vongolo_Knist
avatar
Vongolo_Knist: I did steps 1-4 (similar steps worked for me with Dark Forces 2) and now i'm asked for jedi knight CD number 2. I bet this is because of the new JKM.exe? What can i do about this?
Use the following version of the unofficial patch, which doesn't ask for the CD. Sorry about that. I'll update my post with this link.

http://s000.tinyupload.com/index.php?file_id=93421313505826690870
avatar
Vongolo_Knist: I did steps 1-4 (similar steps worked for me with Dark Forces 2) and now i'm asked for jedi knight CD number 2. I bet this is because of the new JKM.exe? What can i do about this?
avatar
jnisbet: Use the following version of the unofficial patch, which doesn't ask for the CD. Sorry about that. I'll update my post with this link.

http://s000.tinyupload.com/index.php?file_id=93421313505826690870
Works like a charm, you're the best.

Thanks!!!
JKDF2.COM appears to be offline. I get an "Account Suspended" error every time I try to access the site, or any of the files.

I just picked up JKDF2 this week, and I'd like to get this patch working.

Any ideas?
avatar
heeljoetar: JKDF2.COM appears to be offline. I get an "Account Suspended" error every time I try to access the site, or any of the files.

I just picked up JKDF2 this week, and I'd like to get this patch working.

Any ideas?
That patch uses dgVoodoo to fix 3D acceleration. You should get the same effect by just downloading dgVoodoo and adding the files from the MS folder to the vanilla game you got from GOG.

http://dege.freeweb.hu/dgVoodoo2/dgVoodoo2.html
Because JKDF2.COM is down and people wanting to download the pre-patched unofficial patch are unable to download it, I've uploaded it and the MotS unofficial patch (bundled together) to PCGamingWiki.com:

https://community.pcgamingwiki.com/files/file/986-jedi-knight-df2-mots-pre-patched-unofficial-patches/
I tried to fix the problem of constantly stuttering cutscenes and this patch ruined my game. Menu colors became corrupted, 3d acceleration corrupts cutscene colors and the game starts with a black screen that you need to navigate through blind in order to see anything, and even after that all the colors that eventually do show up are corrupted. Now I'll have to uninstall and do everything I did to make the game work in the capacity it did in the first place. Thanks.

EDIT: The patch also breaks NVidia aspect ratio scaling so if you were thinking of playing with the default FOV in one of the 4:3 resolutions, then tough luck. It's 1080p and miniscule HUD elements for you, and better go shopping for that FOV patch for your widescreen game.
Post edited January 12, 2018 by Platinumoxicity
avatar
Platinumoxicity: I tried to fix the problem of constantly stuttering cutscenes and this patch ruined my game. Menu colors became corrupted, 3d acceleration corrupts cutscene colors and the game starts with a black screen that you need to navigate through blind in order to see anything, and even after that all the colors that eventually do show up are corrupted. Now I'll have to uninstall and do everything I did to make the game work in the capacity it did in the first place. Thanks.

EDIT: The patch also breaks NVidia aspect ratio scaling so if you were thinking of playing with the default FOV in one of the 4:3 resolutions, then tough luck. It's 1080p and miniscule HUD elements for you, and better go shopping for that FOV patch for your widescreen game.
I'm sorry to hear that. It's a good idea to always make backups when you overwrite files. Simply making a copy of JK.EXE that you could copy back would've avoided the need for you to re-install the game. Anyways, at this point, in order to avoid having to re-"do everything I did to make the game work," simply re-install JK to a different folder and then copy JK.EXE from that new installation to your original installation. Then, your original installation will be back to how it was before and you can uninstall the new installation.
Post edited 5 days ago by jnisbet