It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So, my copy of Jedi Knight, acquired via GOG, worked just fine for the first seven levels - up to beating the first Dark Jedi (Yun).

But then at the start of level 8 (escaping from the building after defeating him), it crashes to desktop without ever loading the level (but after showing the cutscene to start the level - Kyle, with lightsabre, fighting off an ambush of stormtroopers with blasters.)

Worse still, when it does so, my text and icons are about 4 times their normal size and I have to reboot to get my desktop screen to appear normal again.

It seemed to work just fine up till then, under the options I was using. I just played it all through from level 3 to 7 without a hitch. My last quicksave is just before the end of level 6 - while it's technically legal to quick-save in a fight, it isn't really practical, and level 7 is the first boss fight.

(Also: If there was going to be a problem with one level that wasn't occurring in previous levels, I am surprised it was *here*, because in the original game, I thought I remember that the switch from CD1 to CD2 occurred one level later, at the start of level 9.)
Post edited January 19, 2016 by jle30303
I literally just ran into the same problem. I can see the loading bar for level 8 but as soon as it fills the game crashes back to the desktop.

(I'm using Windows 8.1)

EDIT: Fixed it. I followed the first 3 steps here and now it works.
gog dot com slash support slash star_wars_republic_commando_copy3 slash crashing_in_general
Post edited January 19, 2016 by mattmartin59