It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello,

when I launched this game for the first time, the aspect ratio was not correct: dark force is a 4:3 game and my screen is 16:9. But Dosbox displayed it in fullscreen with a 16:9 ratio, it stretched the game on my 16:9 screen, very uggly with poor performance.

To change that, I opened the conf file "dosbox_DF.conf" and change this value:

[sdl]
fullresolution=desktop
fulldouble=true
output=overlay
windowresolution=1280x1024 #adapt this resolution to your need/screen configuration

[render]
aspect=true
scaler=none

Now I can play the game in fullscreen with a 4:3 ratio and with normal performance.

Another thing: on Linux, you can use output=opengl or output=openglnb

openglnb means nobilinear filter if you want to obtain an image like the original game, without blur

Hope this help.
Post edited January 23, 2015 by legluondunet
Hi,

you don't need to edit the config file. There is a "clean" solution via "Dos box configurator" to set aspect ratio/window mode/graphic api/window resolution. You can find it in the game folder as a link called "Dosbox Configurator".

Cheers
Not on the Linux version. But it's not important, change 2-3 options in a text file is not a hard task.
Sorry guys for commenting in this topic, but i have a problem with the game. When I start it only brings in black screen and nothing more. Can you help solving it?

Thanks a lot :)
avatar
legluondunet: Not on the Linux version. But it's not important, change 2-3 options in a text file is not a hard task.
Yeah you are right, but I always prefer the predetermined solution from gog, if there is one. :)
avatar
ATomi1990: Sorry guys for commenting in this topic, but i have a problem with the game. When I start it only brings in black screen and nothing more. Can you help solving it?

Thanks a lot :)
I would recommend you to create a new topic and add more information about your system (OS, graphics...). So more people read your post and can help you.
Small correction: As far as I can tell, only the cutscenes and possibly some of the sprites are 4:3. Actual gameplay (in particular, the level geometry) is mostly drawn assuming an 8:5 ratio. Since that's what you see the most of, that's the ratio I use.
avatar
Cpt.Obvious: Hi,

you don't need to edit the config file. There is a "clean" solution via "Dos box configurator" to set aspect ratio/window mode/graphic api/window resolution. You can find it in the game folder as a link called "Dosbox Configurator".

Cheers
It's not possible to set ratio.
Thank you !!!

It worked like a charm...

Not just for this game (Star Wars Dark Forces),

but for other dosbox based games as well...

Thank you !!!
avatar
legluondunet: ...
I opened the conf file "dosbox_DF.conf" and change this value:

[sdl]
fullresolution=desktop
fulldouble=true
output=overlay
windowresolution=1280x1024 #adapt this resolution to your need/screen configuration

[render]
aspect=true
scaler=none
Post edited June 03, 2019 by osmanvielma