It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hey guys,

I was wondering if anyone else on the GOG forums has gotten Dark Forces II to successfully run in windowed mode. I have Windows 8.1, 16 GB of RAM, a Nvidia GTX660 GPU, and I'm running the game off of my secondary hard drive. According to PCGamingWiki, the game should run if I set the Display Device to DIBsection Windowed Display, but when I select that option to run at 1024x768, the game does not seem to respect this setting and remains in full screen.

Does anyone else have this issue? Thanks in advance!
No posts in this topic were marked as the solution yet. If you can help, add your reply
http://s30.postimg.org/kozu0uk6n/jkvood.png


Try dgVoodoo.
http://dege.freeweb.hu/
Might also wanna try DxWnd: http://sourceforge.net/projects/dxwnd/
Hey, it's been a while and I've been busy with stuff, so sorry about that. Mind if I see your DirectX settings for dgVoodoo? Dark Forces 2 still seems to crash when I try starting up a new game, so I think I've been configuring dgVoodoo wrong. Additionally, the game still starts up in fullscreen (possibly due to being forced to), so I'm not sure if I can change that on Windows 8.1.

Oh yeah, and thanks for dgVoodoo! It seems to work fine with getting Clive Barker's Undying in Windowed mode with 3DFX mode enabled!
avatar
thesmashingone: Hey, it's been a while and I've been busy with stuff, so sorry about that. Mind if I see your DirectX settings for dgVoodoo? Dark Forces 2 still seems to crash when I try starting up a new game, so I think I've been configuring dgVoodoo wrong. Additionally, the game still starts up in fullscreen (possibly due to being forced to), so I'm not sure if I can change that on Windows 8.1.

Oh yeah, and thanks for dgVoodoo! It seems to work fine with getting Clive Barker's Undying in Windowed mode with 3DFX mode enabled!
Here you are:
Attachments:
jkvoodoo.jpg (79 Kb)
avatar
thesmashingone: *snip*
avatar
teleguy: Here you are:
Hm, I don't think the game likes my hardware/software config. I've also tried switching back to XP compatibility mode, but it appears that the game still prefers to run on software render mode and crashes when I switch it to hardware rendering. One last question, do you have the same video settings that I do in JK2? See the picture below for what I mean.

Otherwise, I think I'm gonna have to give up for now. Thank you again for your help!
Attachments:
No, there are a lot more resolutions available. Can you post a screenshot of the Advanced tab?
avatar
teleguy: No, there are a lot more resolutions available. Can you post a screenshot of the Advanced tab?
Here is a screenshot of my advanced tab. Additionally, just to make sure I'm not placing the dgVoodoo files in the wrong place, the files "D3DImm.dll," "DDraw.dll," and "dgVoodooSetup.exe" should all be going into the root of the Dark Forces 2 folder, as seen in the second picture, correct?
Attachments:
df2dg.png (60 Kb)
Yes, everything is as it should be.
I think you should report the issue here:
http://www.vogons.org/viewtopic.php?f=9&t=34931