It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hey there!

I'm trying to get Jedi Knight to run, but every time I start it up, I get this error:

"The application was unable to start correctly (0xc0000022). Click OK to close the application."

OK, what am I supposed to do here? Do I need to install as admin or something?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
RawSteelUT: Hey there!

I'm trying to get Jedi Knight to run, but every time I start it up, I get this error:

"The application was unable to start correctly (0xc0000022). Click OK to close the application."

OK, what am I supposed to do here? Do I need to install as admin or something?
I don't know about this error, but GOG always recommend you install as admin, so if you didn't then definitely try uninstalling and installing as administrator.

Maybe your system specs might help someone to help you?
avatar
RawSteelUT: Hey there!

I'm trying to get Jedi Knight to run, but every time I start it up, I get this error:

"The application was unable to start correctly (0xc0000022). Click OK to close the application."

OK, what am I supposed to do here? Do I need to install as admin or something?
avatar
korell: I don't know about this error, but GOG always recommend you install as admin, so if you didn't then definitely try uninstalling and installing as administrator.

Maybe your system specs might help someone to help you?
Here's the specs, first.

Windows 8.1
AMD FX-8350 cpu
AMD Radeon R7 270
8GB system RAM.

Secondly, I tried to install as admin, and no change.
avatar
RawSteelUT: Secondly, I tried to install as admin, and no change.
In that case, we should start with the other standard fix attempts:

Are your graphics drivers up to date? Which version of them are you using?

Being as you are on Windows 8, do you have a legacy DirectX9.0c installation done yet? If not, get it installed from the Microsoft download site. You'll be looking for a DirectX9 June 2010 redistributable, and then the web installer.

Next up, make sure you send in a support request to GOG. They'll have other tasks to try to see if they can fix it. And worst case scenario, if it can't be fixed you'll be able to get a refund.
avatar
RawSteelUT: Hey there!

I'm trying to get Jedi Knight to run, but every time I start it up, I get this error:

"The application was unable to start correctly (0xc0000022). Click OK to close the application."

OK, what am I supposed to do here? Do I need to install as admin or something?
Hey man , i know it's been long but did you eventually get it to work because the same error is troubling me to no end...... :(
avatar
RawSteelUT: Hey there!

I'm trying to get Jedi Knight to run, but every time I start it up, I get this error:

"The application was unable to start correctly (0xc0000022). Click OK to close the application."

OK, what am I supposed to do here? Do I need to install as admin or something?
avatar
Razorfist2016: Hey man , i know it's been long but did you eventually get it to work because the same error is troubling me to no end...... :(
It worked on a new Win8 install. I'll have to try it again now that I'm on win10, but I expect the result to be the same.
avatar
Razorfist2016: Hey man , i know it's been long but did you eventually get it to work because the same error is troubling me to no end...... :(
avatar
RawSteelUT: It worked on a new Win8 install. I'll have to try it again now that I'm on win10, but I expect the result to be the same.
The fact that gog support won't answer me back is all the more infuriating...........i guess they only reply to users with several purchases coz i only purchased dark forces 2.

Btw , did you contact gog support , i mean they can't ignore everyone can they ???
Holy mother of all that is good and pure !!!!!!!!!!!!!!!! , go and enable direct play from " turn windows features on/off " from the add/remove option in the goddamn control panel !!!!!!!!!!!!!! , i'm feeling the nerd high right now !!!!
Post edited January 09, 2016 by Razorfist2016
avatar
Razorfist2016: Holy mother of all that is good and pure !!!!!!!!!!!!!!!! , go and enable direct play from " turn windows features on/off " from the add/remove option in the goddamn control panel !!!!!!!!!!!!!! , i'm feeling the nerd high right now !!!!
Awesome! Great that you were able to figure out what was going on! Gonna have to try that.