It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Sorry to start a new thread here, but I've been seeing a few threads on SFC not working with various Windows setups, but I didn't want to derail any of those.

I'm just posting this to say that I had constant crashes on my Windows 8.1 setup, but when I tried it under WINE on my Linux (Ubuntu 14.04 LTS) machine it seemed to run much better, and I was able to complete multiple missions without any problems.

So, if you're one of the users having problems, but have a Linux setup as well, you may as well give it a go.

Oh, one other thing -- the GOG installer appeared to give a few errors at the end of installation. I just clicked OK on each of them and everything seemed to be fine. After that, I just double-clicked the icon on the desktop, and the game just ran as normal.
Post edited June 16, 2015 by blakstar
Just had it freeze during the Destroyer Technical academy mission. I completed it later, but there seem to be occasional long freezes (several seconds), and this may have been a freeze that simply never unfroze. Does this happen to you much?

How do you run it? Anything you've done that improves the choppiness?
I don't know how Wine-powered games are actually stored in Linux, but you can search for the game's directory, open sfc.ini in a text editor and change the value async=1 to 0 in the [Mouse] entry. That seems to be the main cause of crashing in pre-SFC3 games.

That's the output when I tried going into the Recruiting Office just now under Federation in a save in which I've already completed most of the Technicals.

Edit: Okay, having tinkered around a lot, it seems to be the save file.
Post edited December 07, 2015 by MackieStingray
Just a quick update here, but for some reason the game stopped working for me after a while -- not sure why, but I wasn't overly strict with checking Wine compatibility over the various updates.

However, I tried running it under a 1280x1024 virtual desktop, and the game worked just fine, hardware acceleration and all.
Running it on wine: wine-3.3 on Manjaro (Arch).
So far, have experienced no problems.
End of install still gives errors, but installed fine and plays, saves, loads saved game.