It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Well.. I am getting closer. I installed the xorg-libraries, but now it says it's missing "ncurses.so.5". I have the ncurses-libraries installed, but they have ncurses.so.6. Hmm..
Attachments:
Hi, so, I tried your wrapper, and if the installation has gone well, I an't start the game. At the splash screen, I get a fatal error "OpenAL: Can't create sound device". And here's the terminal output:

Current desktop resolution: 1600x900
Gamma (R/G/B) = 1.000 / 1.000 / 1.000
Userdata directory: /home/aesbeth/.local/share/stalker/cop
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Running: ./bin/xrEngine.exe
Not forcing virtual desktop
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
ALSA lib conf.c:3357:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default
AL lib: (EE) ALCplaybackAlsa_open: Could not open playback device 'default': No such file or directory
-> Red 1.000, Green 1.000, Blue 1.000
<- Red 1.000, Green 1.000, Blue 1.000

Any idea?
avatar
killiox: ALSA lib conf.c:3357:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
Check that you have all the required dependencies installed. It looks like you're missing libasound2-plugins:i386 (or your distro's equivalent) at least
Hello,

I have all the dependencies installed, yet midway through the installation, the terminal closes. In the STALKER CoP directory, the docs and support folders are empty, and the start.sh file is absent. Do you have a previous version of your "stalker_cop_wine.tar.xz" file available?

Thank you

EDIT: The issue was resolved when I installed unrar (sudo apt-get install unrar). I no longer need a previous version of the script. Leaving this in case anyone else has a similar issue in the future.

Thank you for your work
Post edited April 01, 2018 by SirLeedle
SirLeedle,

I wish I hadn't just read adamhm's first post and actually perused the whole thread. I had the same problem. Didn't take me more than 10-15 minutes to figure it out though. At first, I thought it wasn't reading the included "innoextract" properly so installed the latest version from the ubuntu repositories...nope.

Then I actually read the command line that said....

Could not extract "setup_stalker_cop_2.1.0.17-1.bin": install `unrar` or `unar`

....and I didn't look like it was opening/able to read the binaries properly...so I did just that. Installed rar unrar....and everything completed just fine.

So, for Ubuntu 16.04 with Intel graphics(HD 640 Iris), the game seems to run great until I actually attempt to start a "new game". Then it freezes my pc. I even started the game in an 800x600 window with the graphics on low...says my graphics card is inadequate(see picture attached below). Is this another title that won't play with Intel graphics? I hope not....I was looking forward to heading into - The Zone!

Still looking for answers, if anyone has a clue...please speak up. Will update if I solve the problem.

Best,

TCG

EDIT: After searching for hours...it look likes it's some sort of direct x issue that is freezing the game? My best guess after spending the night on it....I'll probably give it a go again tomorrow.
Attachments:
Post edited April 23, 2018 by TheCoinGuy
Sorry for the late reply, I've been a bit busy.

avatar
TheCoinGuy: ....and I didn't look like it was opening/able to read the binaries properly...so I did just that. Installed rar unrar....and everything completed just fine.
GOG uses RAR archives for some of their installers... where this is the case innoextract needs to use unrar to unpack them.

avatar
TheCoinGuy: So, for Ubuntu 16.04 with Intel graphics(HD 640 Iris), the game seems to run great until I actually attempt to start a "new game". Then it freezes my pc. I even started the game in an 800x600 window with the graphics on low...says my graphics card is inadequate(see picture attached below). Is this another title that won't play with Intel graphics? I hope not....I was looking forward to heading into - The Zone!

Still looking for answers, if anyone has a clue...please speak up. Will update if I solve the problem.
Unfortunately I had issues with the STALKER games on Intel graphics :( They did run, but not well. Still, that was with a weaker iGPU & there are some things you can try, if you haven't tried them already.

First make sure your kernel is the most recent available so you're using the latest available driver modules.

Then uninstall the package "xserver-xorg-video-intel" - this is for older Intel GPUs and can interfere with newer ones. Use this command to remove it:

sudo apt-get remove xserver-xorg-video-intel

Next make sure you have a recent Mesa release, as 16.04's version is quite old. Add this PPA and then update your system:

Padoka's Stable Mesa PPA

Then finally restart the system and try Call of Pripyat again :)
Post edited May 08, 2018 by adamhm
Well...

Still a no go...but at least I'm not getting the error. Although, instead of the error it just freezes the game in the exact same spot. Up until that point, the menu's work perfectly, very smooth. I can change any setting with no hassles and the graphics are crisp. It's just when I start a "New Game"...the weirdness happens.

I'm not sure whether it's the updated Mesa driver or getting rid of the old x.org driver...but my system seems to be running quite smooth. Definitely an improvement....a mild improvement, but I'll take it.

I've been playing Mad Max over the last couple of weeks, so I haven't thought much about Call of Pripyat...if my Intel Graphics can handle Mad Max @ 1080p on high settings, it should "graphically" be able to handle an old STALKER game? Is it just that the Intel drivers aren't supported as well? or at all?

At any rate, if anyone comes up with any new ideas to try, I'm more than game. I've been wanting to play this series for years.

adamhm...thanks, yet again....for trying to help. You're a true asset to the linux gaming community.

My regards,

TCG
Hey, is there any way to make Max come back alive? The freedom leader keeps telling me to talk to him, but he's dead.