It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello,

I'm playing S.P.A.Z. on Windows 7 machine with administrator account, but every single time I double-click the shortcut the screen flashes and windows asks me do I want to allow this program from UNKNOWN publisher to make changes to my hard drive, why is that does, the game install something every time it is started?
This question / problem has been solved by HunchBluntleyimage
No, it's not trying to install anything extra; it's just Windows being overly cautious. It's what's know as User Account Control (UAC). If you trust all the programs you have installed, you can just change the UAC setting to a less restrictive one (or turn it off altogether, as many people do). This can be done in the Windows Control Panel.

The alternative is disabling the "Run as Administrator" option in the Properties for whichever individual programs you want to do this in. (Some games work better when run as Administrator, though, which is part of the reason why most GOG installers set them up that way; I've played SPAZ with that option turned off, though, and it worked fine for me in Windows 8.1). If you want to turn off the "Run as Administrator" option:
- Right-click on the game icon
- Click "Properties" (at the bottom of the menu)
- Click the "Compatibility" tab at the top of the Properties panel
- Look for a check box near the bottom that should say something like "Run this program as an administrator", and make sure the box is unchecked
-Click "OK"

Unless Windows 7 treats this game differently than Windows 8 does, that should get it to stop bothering you with that notice every time you try to run SPAZ. Note that you can try this with other programs, too, but, like I said, some games don't work quite right unless they're run as Administrator. (Also, I've got one or two games that still give the "Unknown publisher is trying to make changes to this computer" message even when the game is not being run as Administrator, so....)
Thanks HunchBluntley! I usually play my GOG games on my old windows XP computer so this was kind a new thing for me :) Btw the game icon, i.e. the shortcut doesn't have compatibility tab in the properties. Also it doesn't have "Find target" but instead "Open File Location" which oddly enough leads to the next shortcut inline in the windows games directory (WTF Bill ?!?). But I managed to find it, for anyone interested just navigate to the folder in wich the game is installed, default being C:\GOG Games\Space Pirates and Zombies and do the steps from ^ HunchBluntley post to the file SpazGame.exe.
avatar
leon30: Thanks HunchBluntley! I usually play my GOG games on my old windows XP computer so this was kind a new thing for me :) Btw the game icon, i.e. the shortcut doesn't have compatibility tab in the properties. Also it doesn't have "Find target" but instead "Open File Location" which oddly enough leads to the next shortcut inline in the windows games directory (WTF Bill ?!?). But I managed to find it, for anyone interested just navigate to the folder in wich the game is installed, default being C:\GOG Games\Space Pirates and Zombies and do the steps from ^ HunchBluntley post to the file SpazGame.exe.
No problem! I am by no means a computer expert, so I'm glad I was able to help someone a little bit with a problem like this. Especially since, as dead as this game's forum is, you might have been waiting awhile for an answer otherwise. =)

As to the differences in the Properties panel, I guess those are just changes made in the interface between Windows 7 (which I've not used) and Windows 8. At least you found it! =D