It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Howdy all,

I installed Solasta, created characters, no problem. Then started running the game --Whew! GPU went to 100% and the fans started cranking!

My system is a little older --I5 3570k with an RX 580 running Windows 7.

Now, I've run GPU benchmark software that will peg everything to see how high you can go. From my perspective, the game seems horribly optimized (ie. brute-forcing graphics with power rather than optimized code).

Yeah, Solasta is a 2020 game. And it's pretty, but for an isometric game, it seems to be over-drawing or drawing inefficiently. I don't see anything in the game which commonly uses that many resources (ie. the kind of rendering that a GPU benchmark program will throw at your GPU).

My solutions:
I set graphics to low. Didn't help. GPU was overheating***
I limited frame rate to 30fps, and that makes the game playable --but with odd GPU results: the GPU cycles between 15% and 100% every second --to create a real sawtooth graph of GPU usage over time. This is where it looks inefficient. Either it's spending way too many resources to draw one frame, or it's drawing 30 frames super fast, then waiting.

***I cleaned out some dust from my GPU. That helped. It's got three big fans on it (won't even fit in most cases). I don't have a case fan blowing on it --that would help. So on the cooling side --yeah I could probably fix that. It's more the weird over-usage constantly demanding 100% when it doesn't look like it really should.

None of my other games do this.
It's been out for a while, enough time for bug-fixes. Is this just an eternal problem with the game, or am I missing something?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Redacted. Misread your post. I apologize.
Post edited March 22, 2022 by J Lo
GPU is supposed to be 100%.
That means it's actually being efficient and using the GPU as it's suppose to.
30 fps is not playable for most people, I'm guessing your system runs poorly in general if you are ok with 30fps.

Your GPU is overheating because your case sucks and you don't have proper ventilation. The sawtooth is probably because it prerenders the frames and then sits there doing nothing because you have everything on low and 30fps.

Turn PC off. Turn power supply switch on the back of the case to off. Wait for capacitors to discharge, there should be no LED indicators on your board, assuming you can see it. Mine usually take about 10 seconds. Then just remove the side of your case. That should be fine but if you want more cooling just buy a cheap, small tabletop fan that you can turn on while gaming and aim it into your case. Never touch anything while it's operating or capacitors have a charge, or you run some risks of static damage.

You didn't say what the temperatures are, just that it's hot. You're probably assuming (which I have to do since you didn't provide enough information) it's hot because you can hear the fans, which is probably true. The point is, you should use HWINFO64 or some other monitoring service to see the temperature so you can get some feedback on what's helping, or to see the difference with the side of the case off. My card idles in the 40's. Some games I play will stay in the 40's, other games will hit 82, both will be 100% usage. Since your card is so hot, activating higher fan RPM, you are probably having thermal throttling which will lower performance as well.
This is a known, but ignored issue with the game.

The problem is not with the "efficiency" of the GPU, the problem is with Solasta's optimization. There are numerous locations which are simply extremely GPU hungry - Dark Castle exterior, or Emerald Valley in the DLC, to name a few. I think we can all agree that this game isn't exactly second Cyberpunk or RDR2 in terms of graphics, yet it consumes GPU power at insane rate.

In some locations, the GPU runs pegged at 100%, with stuttering and low frame rate - on a RTX 3070 (I have around 40 fps in the initial area of Emerald Valley, granted everything on ultra / 1440p, but that is way way too low for this kind of hardware).

It was the same on my GTX 1080 before, only without shadows. It seems that shadows and possibly lighting in some locations create this problem. Lowering graphical details does not help - only turning shadows completely off helps. The same problem occurs on a laptop with 3060, and older computer with Radeon Fury X - it's not tied to a specific vendor, driver, or card.

Also, not all the parts of the GPU are being put to work - hwinfo and Windows all register 100% utilization, yet my 3070 stays around 60-65 degrees Celsius. It is quite a bit above that during Cyberpunk or 3DMark testing. Also, hwinfo reports severe memory bus under-utilization, which leads me to believe that there is some kind of bottleneck that the game creates.

This problem was mentioned several times on Steam forums, Solasta forums, even during the early access. Of course it was ultimately ignored by the devs.

It is true that OP had a problem with dust and insufficient cooling. But he is right - no other game does this, it uses way too much resources for what it looks like, and the root problem is with the game, not hardware.
Post edited April 25, 2022 by BlueBangkok
This is a known issue with Unity Engine (could it be some problems with implementation?). The only working solution so far is to enable Vsync.
cielaqu: This is a known issue with Unity Engine (could it be some problems with implementation?). The only working solution so far is to enable Vsync.
That is not a solution as enabling Vsync does not help. I have been playing with Vsync on the entire time.
For me the difference is ~600W power consumption with Vsyns off and ~250W with Vsyns on.
The first game I noticed that happening was The Dwarwes, same situation, also Unity engine. But not all games on Unity engine exhibit such behaviour, Homoworld is fine for example.
If enabling Vsyns doesn't lower GPU usage, try limiting framerate in drivers.
Try also searching the internet for high gpu and cpu usage for Unity, there will be many topics on that.
unless your GpU shut itself off, it did NOT overheat. They are supposed to run, at 100%, or very close to it. It's how they are designed. Any nr of games runs my CpU/Gu temps into the 83-87c range, while sitting idle they are in the 35-40c range. That's what cooling fans are run hard when need be, and to run quietly when they aren't critical.