It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

TLDR: Getting a "Memory Allocation Error" crash at startup? Check if you have large files (>2GB) in your root system partition (usually C:\). Delete or move them elsewhere.

After starting the game a dozen times without any issue, it suddenly crashed with the message "Memory Allocation for 4294967232 Bytes failed". Perplexed, I've googled and tried all the possible solutions to this error, even knowing that it makes no sense, since the game worked fine before.
Nothing helped obviously. WTF, how can a game crash all of a sudden, even after deleting all saves, configruation files and reinstalling it, without doing any changes on the os whatsoever?
Turns out: I did change something. I've dowloaded Stalker Anomaly and moved it to my windows drive (where SGW3 is installed). Yeah right, a totally unrelated single 9 GB zip file under C:\ is causing this game to crash!
I've tried other file sizes and extensions. The extension doesn't matter, but every file bigger than 2 GB (except the page file) leads to this issue, at least on my system with 16GB RAM.
So apparently the cryengine of this game reads/parses the files on your system root, for whatever reason, and crashes with a memory allocation error.
The solution provided in this topic needs a little bit of correction:
if a CryEngine Error saying that *** Memory allocation for 4294967295 bytes failed *** occurs during the CI Games logo is shown after launching the game, remove all the files whose sizes are equal to or larger than 2 GB from the partition where the game is installed, or install the game else where to avoid it being together with files of said sizes in the same partition.

Long story short:
I installed the game in a partition other than C drive which has many files of GBs in size. There was no large file in the boot partition, still that error occurred. So I reinstalled the game in an empty partition and the error was no more. I tried to create some single files of certain sizes by using WinRAR making split archives, then sent them to C drive and the partition where the game was reinstalled. The error popped up again once the size of the file, which I sent to the game's partition, reached 2048 MB. Any sizes under 2 GB, for example 2047 MB, would not trigger the error, neither would files of any sizes that sent to C drive.
So it leads to the conclusion that for whatever reason files are not smaller than 2 GB in the same partition where the game is installed will trigger a memory allocation error making the game unplayable.

Many thanks to russellskanne because if not this post of yours I would not figure it out. Cheers!