It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just bought this game, but I can't make it run. When launched from a terminal, I get this output:

Running Slipstream
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=lcd
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.lwjgl.LWJGLUtil$3 (file:/tmp/.mount_slipstsyB8oo/usr/bin/slipstream) to method java.lang.ClassLoader.findLibrary(java.lang.String)
WARNING: Please consider reporting this to the maintainers of org.lwjgl.LWJGLUtil$3
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Exception in thread "LWJGL Application" java.lang.ExceptionInInitializerError
at com.badlogic.gdx.backends.lwjgl.LwjglGraphics.setVSync(
at com.badlogic.gdx.backends.lwjgl.LwjglApplication$
Caused by: java.lang.ArrayIndexOutOfBoundsException: Index 0 out of bounds for length 0
at org.lwjgl.opengl.LinuxDisplay.getAvailableDisplayModes(
at org.lwjgl.opengl.LinuxDisplay.init(
at org.lwjgl.opengl.Display.<clinit>(
... 2 more
AL lib: (EE) alc_cleanup: 1 device not closed

What I tried:
Install sndio
Install jre-openjdk-11
Add LANG="C" to the start script before the actual game launch

Operating System: Arch Linux
Kernel Version: 5.1.5-arch1-2-ARCH
OS Type: 64-bit
Processor: i7-4790 CPU @ 3.60GHz
Memory: 15,6 GiB
NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)

I know that only Ubuntu is officially supported, but I rarely have issues with other games on Arch
Post edited May 31, 2019 by g.reventlov
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have the same exact problem under Debian and i also tried the same "fixes" as you. I Hope someone can help
In the end I changed my distro to kubuntu, after trying this game and others. Now it's working. I don't know what was causing the problem.