It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Edit#3: GoG is now working again. Thank you, Ironclad.

I've recently been unable to connect to ICO.
Whenever I attempt to connect, it returns an error message stating "Disconnected from Ironclad Online".

I believe the issue started during a game with two other players.
About two hours in, the game stopped due to a lag issue, but this specific occurrence was unusual because the game remained stuck for about ten minutes without anyone disconnecting. I checked my own connection during this and could access Google and other websites just fine.
Eventually one of the players quit, and the game resumed, but only in small intervals (it would stop/go repeatedly).
After a minute or so, the issue went away and the game resumed normally, but the game host was afk.
I met up with the game host in channel, and we tried to load the saved game, but I could not locate his game lobby.
I tried changing channel to Lobby 1, but the game would not switch channels.
I tried logging out and logging in to ICO, but the connection attempt appeared to time-out.
I exited the game and started it again, but the connection attempt still timed-out.
I made a few more attempts, and eventually, instead of timing-out, it would show "Disconnected from Ironclad Online" immediately after clicking the ICO button.

I asked another Steam user (that was playing Sins at the time), and he reported no issues with ICO.
I have made several attempts to fix the issue on my end, but it seems nothing has worked so far.
#1: I have checked that the rebellion.user.setting file specifies "ico-reb.stardock.com" as the IcoServerAddress and 8000 as IcoServerPort
#2: I have tried deleting the rebellion.user.setting and letting Sins generate a new one.
#3: I have tried verifying the game files using GoG Galaxy.
#4: I re-imaged my entire PC to a state roughly 24 hours before I began having issues.
#5: I have checked that there are no firewalls blocking Sins from accessing the internet.

My current guess is that ICO is possibly rejecting my connection attempts for some unknown reason.
The other Steam user had no issues, so this issue seems specific to me.
The re-image to a "working state" had no effect, so it is not something that appears to be fixable via file/registry.
I watched the network activity, and the TCP connection to ICO does not appear to be timing-out anymore but is (instead) being closed immediately.
Edit#1: Network connectivity is not an issue. Steam version of Sins can connect to ICO.

Is there any other possible solutions to try to fix this connection issue?

Edit#1: I've uninstalled the GoG Sins and tried installing the Steam version (I bought Sins on Steam and GoG). Strangely, the Steam version can connect to ICO. Network activity shows it is still connecting to the same IP address as the GoG version, so network connectivity is not an issue. Will try re-installing GoG version again.

Edit#2: A full GoG re-install does not work. ICO seems to be blocking my GoG game client or GoG account.

Edit#3: GoG is now working again. Thank you, Ironclad.
Post edited June 07, 2017 by FishInSpace