It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I set up the Ultimate SiN Patch and from what I understand, it's set up for 1920x1080 which is my monitors native resolution. However, when the game starts, it flickers like crazy, as if the frequency is off, but I see no way of adjusting it.
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Astaldo711: I set up the Ultimate SiN Patch and from what I understand, it's set up for 1920x1080 which is my monitors native resolution. However, when the game starts, it flickers like crazy, as if the frequency is off, but I see no way of adjusting it.
Have you tried the Sin Patcher from http://sin.nanoaugur.net/? I tried Ultimate SiN patch at first but I still had problems with the game so I went to PCGamingWiki and the Sin Patcher fixed the game for me.

1. Download a Sin Patcher for either 1.11 retail or 1.12 Steam.
2. Move it to the installation folder and run it.
3. Type in your desired resolution values and click Apply resolution.
4. Start a game and select 1152x864 resolution in game's options.

(Info taken from https://pcgamingwiki.com)
Thanks, but this didn't help. With this, the game goes into a black screen. I have to alt-tab several times to close it, sometimes even bring up the task manager to close it.
I have a Radeon 550 4gb card and 6gb ram Win7
Maybe try changing the gamma setting in nGlide? It seemed to work for other people.