It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
This problem is caused by the scrolling mechanism that is tied to the speed of the CPU. Since CPU speeds are dramatically faster than in the late 90s, we have scrolling speed that are now way too fast.

Under Control Panel | Power Options set up a plan to use for a game (in this case SimCity 3000). Select "Change Plan Settings" on that plan and then Select "Change Advanced Power Settings". Then select the "+" to expand "Processor Power Management". Then select the "+" to expand "Maximum Processor State". Set the maximum to 25%. Scrolling is reasonable. You may have to set the max higher or lower, depending on your computer and scrolling speed preferences.

Make sure the Plan with slower CPU is selected currently and your good to go. After using SimCity reset the Power Plan to the usual ("Balanced" on my computer) to get the CPU going fast again.

Source: Matrix Games Forums
Too bad scrolling is tied to the CPU clock. Is there not an unofficial patch that solves this without underclocking my CPU?
It`s things like this that GOG should maybe try to fix considering they where good at improving games on newer systems.

Things like.....

mouse scrolling
change some of the music that is mono, to stereo
enable the 2 or 3 songs that arnt enabled in the music settings file
add widescreen resolutions
Or use my guide to get the game running using DxWnd.
DxWnd has a built-in framerate limiter that will mostly fix the main problem. And if you want you can follow the extra steps to make the UI/fonts look bigger on the screen.

https://www.gog.com/forum/simcity_series/fixed_these_problems_using_dxwnd_map_scrolling_speed_high_cpu_usage_small_textui/page1
avatar
FeelingShred: Or use my guide to get the game running using DxWnd.
DxWnd has a built-in framerate limiter that will mostly fix the main problem. And if you want you can follow the extra steps to make the UI/fonts look bigger on the screen.

https://www.gog.com/forum/simcity_series/fixed_these_problems_using_dxwnd_map_scrolling_speed_high_cpu_usage_small_textui/page1
I tried this, but it doesn't work for me. Used expert mode and tried to follow the instructions to the letter, but no matter what I do, scroll speeds stay as they were :( Makes the game unplayable really, when you just swoop over the whole map with 1 fast keypress.
avatar
Ghammakhur: This problem is caused by the scrolling mechanism that is tied to the speed of the CPU. Since CPU speeds are dramatically faster than in the late 90s, we have scrolling speed that are now way too fast.

Under Control Panel | Power Options set up a plan to use for a game (in this case SimCity 3000). Select "Change Plan Settings" on that plan and then Select "Change Advanced Power Settings". Then select the "+" to expand "Processor Power Management". Then select the "+" to expand "Maximum Processor State". Set the maximum to 25%. Scrolling is reasonable. You may have to set the max higher or lower, depending on your computer and scrolling speed preferences.

Make sure the Plan with slower CPU is selected currently and your good to go. After using SimCity reset the Power Plan to the usual ("Balanced" on my computer) to get the CPU going fast again.

Source: Matrix Games Forums
Thanks, that works :)
Just FYI neither the OP (which I did not try) nor FeelingShred's solution fixed this for me.
Patching the EXE for a desktop resolution fixed my scrolling speed.
I used this one https://www.gog.com/forum/simcity_series/simcity_3000_widescreen_patch_instructions/post3

Appreciate the efforts, lads
This is how I finally ended up resolving the fast scrolling issue, after trying patches, python scripts, DXwnd, changing settings for Nvidia, and none of this worked.

I am on a Lenovo legion laptop so this really did not make sense but I downloaded the widescreen version . The forum will not let me post the link so replace XXXX with https://

XXXXsupport.gog.com/hc/en-us/articles/360018687573-Simcity-3000-Unlimited-widescreen-support?product=gog

I put it on the highest resolution, which is what this patched file was meant for.

Pleasant side effect- the fast scrolling issue vanished.

Enjoy :-)
Sorry to revive a dead thread, but i'm also encountering this and its super annoying/

does anyone have any word on a fix?