It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

My system specs:

Zotac Zbox EN1070
i5 6400T, GTX1070, 16GB ram, running on SSDs.
Using latest version of Windows 10. (1909 and update for May)

Initially I could not get the game to launch past the video but that was solved by skipping it. Now I have 2 issues.

If I run the game from the shortcut the game crashes after about 5 seconds on the map screen.
I changed some of the settings in the shortcut like renderer to DirectX which instantly crashes, OpenGL and software both crash after about 5 seconds on the map screen.

I tried SC4 Launcher and also change my settings there only for it to still crash.

Anyone having similar issues? Any possible fixes?
No posts in this topic were marked as the solution yet. If you can help, add your reply
I found the fix myself.

I am running the game on a different PC and having a lot less issues. It came down to the sound that had to be disabled.

I also ran into a problem with opengl where the game would render the areas white. This is resolved by switching to direct3d but there is also a limit to this. Direct3d is used by -d:directx and the maximum resolution usable is 1920x1080 when using custom resolutions.