It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


so I got this and in my library in states that there are several different languages available, but no matter which one I choose, I always end up with the same installer, only containing English and French. Tried with and without GOG download tool. Seems there are no in-game options to change the language as well.

Help appreciated! :)
Post edited March 14, 2015 by emotica
run "Language Setup.exe"
Doh! Thanks a lot!
Doesn't work for me.

I altered the desktop icon to make the game run in a hd resolution before, but I don't know if that's the reason why it doesn't work. Is there just an argument in the target field to set up the language?
Running "Language Setup.exe" as Administrator helps!
OrphanCat: Running "Language Setup.exe" as Administrator helps!
Thanks a lot. :)