It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Updating the thread with links to the DxWnd config file and screenshots...

https://www.dropbox.com/sh/ulmxs017alsicnh/AACMk8nf8ZSKr_NlibV9l9GRa?dl=0

Screenshots of how the game runs with these settings:
https://imgur.com/a/3Mt5EA7

Original text:

Hey guys I found a fix for pretty much all Simcity 3000 problems when running in modern machines. I first tried the game this year but it was impossible to play with the insane map scrolling speeds, and I also noticed my CPU usage was very high while the game was running. A while ago I found this great tool for me to play Delta Force 1 in window mode and mouse aiming working. I tried Simcity 3 on it and it works too. The tool is called DxWnd, it's similar to D3Dwindower (I guess, never used that), but with much more advanced features.

Following the guide below you will be able to:
1) Play the game with a framerate-limiter, this will solve the scrolling speed problem and lower CPU usage to normal levels for such an old game.
2) Play the game on window mode, in a window which will occupy all your desktop height resolution while scaling up the user interface, so the text is readable even with high desktop resolutions (filtering is needed as mentioned)

:: I'm playing the game on a Linux laptop, inside Wine (a Windows emulator) and DxWnd running inside of it, so pretty much 2 levels of emulation, so if it works for me should work for everyone. While the game runs, it uses 100 MB of RAM and only 20% of CPU usage (old dusty laptop). Below is the same guide I posted at the WineHQ database on how to set up the game with DxWnd, hopefully it's not too confusing, I tried to make the text short (but this summary is already too long, OMG) ::

TLDR Guide...
:: GUIDE :: When you use DxWnd for the first time, be sure to select "Expert Mode" at the menu, this will show many more tabs, including the "Timing" one.
1) First of all, right click and select Add, to add a shortcut to the game, a launcher.
2) In order to force framerate-limit, go to the "Timing" tab, in the "Frame per second" area, check the Limit box and type 50 (msec). This will give you a 20 FPS limit. You can fine tune this value to your tastes, 20 is fine for me. Scrolling problem solved!
3) Now, to scale the game to a big window with big text: In the "Main" tab, check Force Aspect Ratio. Down below, type "Initial window size" 928x704 (depends on your desktop resolution) and check "Desktop Work Area", this will give you a borderless window occupying all available vertical resolution leaving reserved space for the taskbar.
4) When you start the game, go to options and select 640x480, this will give you big user interface but zoomed-in to a bigger window.
5) On the "Input" tab, select "Correct Mouse Position", "Release Mouse Outside Window" and "Message Processing something" (without this last one the mouse will jump when you are selecting budget options and such.
6) On the "DirectX" tab, select Filter "Fast Bilinear 2x", this will make the text readable and get rid of most pixelation.
:: That's it, you can play the game now. Backup your DxWnd settings using the "Export" option.
Attachments:
Post edited April 12, 2021 by FeelingShred
I have just downloaded two versions of DxWnd and followed your instructions verbatim. It doesn't work.

Whenever I open the game through DxWnd and as the Adminstrator, it simply ignores all of the modifications, loads fullscreen and continues to have incredibly fast scrolling which has now rendered the game uplayable.
Oh missed your reply, sorry... So much spam on the email I didn't get notifications for this...
So, were you able to finally make the game work? I can help you if you still need it

Did you go to Options and checked "Expert Mode" on?

Also, my shortcut looks like this:
C:\HOME\simcity3000\Game\SC3.EXE -w -r640x480

Screenshots attached...
Attachments:
tab1hook.png (15 Kb)
tab2main.png (19 Kb)
avatar
FeelingShred: Oh missed your reply, sorry... So much spam on the email I didn't get notifications for this...
So, were you able to finally make the game work? I can help you if you still need it

Did you go to Options and checked "Expert Mode" on?

Also, my shortcut looks like this:
C:\HOME\simcity3000\Game\SC3.EXE -w -r640x480

Screenshots attached...
https://support.gog.com/hc/en-us/articles/360018687573-Simcity-3000-Unlimited-widescreen-support?product=gog
this work for me... the theme iamges and videos are small but since u enter in the game, u gonna see its fullscreen
Updating the thread with links to the DxWnd config file and screenshots...

https://www.dropbox.com/sh/ulmxs017alsicnh/AACMk8nf8ZSKr_NlibV9l9GRa?dl=0

Screenshots of how the game runs with these settings:
https://imgur.com/a/3Mt5EA7