It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


Found this problem at the very start of the game. When i reach the first chronicler and try to save game, it wont work! Game will get to the save game screen, and I can choose which file to save, and it lets me write my save game name, bat after that it doesn't save it. It just don't regognize enter or anything else to "finish" writing and saving. Only pushing esc works, but it cancels saving.

What should I do?

I'm playing with fairly new HP Laptop with Windows 7, ATI videocard and AMD processor.
Tried with administrative mode, didn't work.
Man, i have a solution for you ! Sure you'll be happy enough with that^^.
I had the same problem and i found the answer in another forum.
This tip really looks strange but it worked for me and i hope it will work for you !
Well :

- when you're on the save screen, press your "lock num" key on your keyboard. Enter the name for your save then press enter.
- well, that's all ^^'.
Terba: Tried with administrative mode, didn't work.
Post edited May 23, 2012 by etrigane
It worked! Thanks!